SitePoint Sponsor

User Tag List

Results 1 to 5 of 5

Hybrid View

  1. #1
    SitePoint Guru ripcurlksm's Avatar
    Join Date
    Aug 2004
    Location
    San Clemente, CA
    Posts
    859
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    New IE9 browser not working with my get form

    Hello, I have a two-step form that posts GET data to the URL and it has been working great for the past few years in FireFox, Chrome, Internet Explorer 7 and 8.

    Here is how its being posted in the browser and works fine:
    Code:
    www.mywebsite.com/page.php?row2009_523=253.3&rowcagr_523=10.5&row2009_524=172.6&rowcagr_524=10.3&row2009_525=10.2&rowcagr_525=14.8&row2009_526=93.1&rowcagr_526=9.8&row2009_527=128.1&rowcagr_527=9.8&row2009_528=76.6&rowcagr_528=10.7&row2009_529=64.1&rowcagr_529=11.0&row2009_530=59.7&rowcagr_5
    However, the new IE9 is posting the GET data as:
    Code:
    www.mywebsite.com/page.php?dataTableArray=a%3A29%3A%7Bi%3A0%3Bs%3A3%3A%22198%22%3Bi%3A1%3Bs%3A3%3A%22199%22%3Bi%3A2%3Bs%3A3%3A%22200%22%3Bi%3A3%3Bs%3A3%3A%22201%22%3Bi%3A4%3Bs%3A3%3A%22202%22%3Bi%3A5%3Bs%3A3%3A%22203%22%3Bi%3A6%3Bs%3A3%3A%22204%22%3Bi%3A7%3Bs%3A3%3A%22205%22%3Bi%3A8%3Bs%3A3%3A%22206%22%3Bi%3A9%3Bs%3A3%3A%22207%22%3Bi%3A10%3Bs%3A3%3A%22208%22%3Bi%3A11%3Bs%3A3%3A%22209%22%3Bi%3A12%3Bs%3A3%3A%22210%22%3Bi%3A13%3Bs%3A3%3A%22211%22%3Bi%3A14%3Bs%3A3%3A%22212%22%3Bi%3A15%3Bs%3A3%3A%22213%22%3Bi%3A16%3Bs%3A3%3A%22214%22%3Bi%3A17%3Bs%3A3%3A%22215%22%3Bi%3A18%3Bs%3A3%3A%22216%22%3Bi%3A19%3Bs%3A3%3A%22217%22%3Bi%3A20%3Bs%3A3%3A%22218%22%3Bi%3A21%3Bs%3A3%3A%22219%22%3Bi%3A22%3Bs%3A3%3A%22220%22%3Bi%3A23%3Bs%3A3%3A%22221%22%3Bi%3A24%3Bs%3A3%3A%22222%22%3Bi%3A25%3Bs%3A3%3A%22223%22%3Bi%3A26%3Bs%3A3%3A%22224%22%3Bi%3A27%3Bs%3A3%3A%22225%22%3Bi%3A28%3Bs%3A3%3A%22226%22%3B%7D&country_id=3&procedure_id=1&table_id=4&x=134&y=12
    Here is a snippet of a piece of the form in question:
    Code:
    <form name="dataedit" action="page2.php" method="get">
    
    		
    <table class="flexme2">
    	<thead>
    	    <tr>
    	        <th width="270" ><br/>Procedure</th>
    	        <th width="66"><br/>2009</th>
    	        <th width="66"><br/>2010</th>
    	        <th width="66"><br/>2011</th>
    	        <th width="66"><br/>2012</th>
    	        <th width="66"><br/>2013</th>
    	        <th width="66"><br/>2014</th>
    	        <th width="66">CAGR<br/>2009-14</th>
    	    </tr>
        </thead>  
    	<tbody> 
        
            
        <tr class=" even">	
    		<td height="20" valign="top"><div align="left" class="mystyle">
    		Liposuction </div></td>
            <td align="right" valign="top"><div align="left"><input type='text' class='datainput' name='row2009_198' value='117.140' ></div></td>
            <td align="right" valign="top"><div align="left">192.110</div></td>
            <td align="right" valign="top"><div align="left">313.139</div></td>
            <td align="right" valign="top"><div align="left">507.285</div></td>
            <td align="right" valign="top"><div align="left">816.728</div></td>
            <td align="right" valign="bottom"><div align="left">1,312.215</div></td>
            <td valign="top"><div align="center"><input type='text' class='datainput' name='rowcagr_198' value='62.1' style='width:40px;'>%</div></td>
    	</tr>
            
        <tr class=" odd">	
    		<td height="20" valign="top"><div align="left" class="mystyle">
    		Breast Augmentation </div></td>
            <td align="right" valign="top"><div align="left"><input type='text' class='datainput' name='row2009_199' value='109.580' ></div></td>
            <td align="right" valign="top"><div align="left">186.286</div></td>
            <td align="right" valign="top"><div align="left">315.755</div></td>
            <td align="right" valign="top"><div align="left">530.468</div></td>
            <td align="right" valign="top"><div align="left">885.882</div></td>
            <td align="right" valign="bottom"><div align="left">1,475.192</div></td>
            <td valign="top"><div align="center"><input type='text' class='datainput' name='rowcagr_199' value='68.2' style='width:40px;'>%</div></td>
    	</tr>
    </tbody>
    </table>  
    <input name="dataTableArray" value='a:29:{i:0;s:3:"198";i:1;s:3:"199";i:2;s:3:"200";i:3;s:3:"201";i:4;s:3:"202";i:5;s:3:"203";i:6;s:3:"204";i:7;s:3:"205";i:8;s:3:"206";i:9;s:3:"207";i:10;s:3:"208";i:11;s:3:"209";i:12;s:3:"210";i:13;s:3:"211";i:14;s:3:"212";i:15;s:3:"213";i:16;s:3:"214";i:17;s:3:"215";i:18;s:3:"216";i:19;s:3:"217";i:20;s:3:"218";i:21;s:3:"219";i:22;s:3:"220";i:23;s:3:"221";i:24;s:3:"222";i:25;s:3:"223";i:26;s:3:"224";i:27;s:3:"225";i:28;s:3:"226";}' type="hidden"/>
    <input name="country_id" value="3" type="hidden"/>
    <input name="procedure_id" value="1" type="hidden"/>
    <input name="table_id" value="4" type="hidden"/>
    <div class="orangenext">
    	<input type="image" src="images/button_steps1.jpg"/>
    </div>
    </form>
    Any ideas why IE9 is now the only browser (no jokes please ) that is treating this GET data differently?

  2. #2
    SitePoint Guru ripcurlksm's Avatar
    Join Date
    Aug 2004
    Location
    San Clemente, CA
    Posts
    859
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Bumping. Also I am noticing that it only happens when I am not running in IE compatibility mode. With compatibility mode on, it works normally. With it off, i get what I posted above.

    Any idea what I am doing wrong (requiring compatibility mode)?

  3. #3
    Under Construction silver trophybronze trophy AussieJohn's Avatar
    Join Date
    Sep 2005
    Location
    Sydney, Australia
    Posts
    776
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ripcurlksm View Post
    Bumping. Also I am noticing that it only happens when I am not running in IE compatibility mode. With compatibility mode on, it works normally. With it off, i get what I posted above.

    Any idea what I am doing wrong (requiring compatibility mode)?
    I just pasted your form in to a HTML file and tested this, it seems to me that this is working as intended.

    These are the URLs I get when I submit the form:
    Code:
    IE9:
    http://localhost/index.html?row2009_198=117.140&rowcagr_198=62.1&row2009_199=109.580&rowcagr_199=68.2&dataTableArray=a%3A29%3A%7Bi%3A0%3Bs%3A3%3A%22198%22%3Bi%3A1%3Bs%3A3%3A%22199%22%3Bi%3A2%3Bs%3A3%3A%22200%22%3Bi%3A3%3Bs%3A3%3A%22201%22%3Bi%3A4%3Bs%3A3%3A%22202%22%3Bi%3A5%3Bs%3A3%3A%22203%22%3Bi%3A6%3Bs%3A3%3A%22204%22%3Bi%3A7%3Bs%3A3%3A%22205%22%3Bi%3A8%3Bs%3A3%3A%22206%22%3Bi%3A9%3Bs%3A3%3A%22207%22%3Bi%3A10%3Bs%3A3%3A%22208%22%3Bi%3A11%3Bs%3A3%3A%22209%22%3Bi%3A12%3Bs%3A3%3A%22210%22%3Bi%3A13%3Bs%3A3%3A%22211%22%3Bi%3A14%3Bs%3A3%3A%22212%22%3Bi%3A15%3Bs%3A3%3A%22213%22%3Bi%3A16%3Bs%3A3%3A%22214%22%3Bi%3A17%3Bs%3A3%3A%22215%22%3Bi%3A18%3Bs%3A3%3A%22216%22%3Bi%3A19%3Bs%3A3%3A%22217%22%3Bi%3A20%3Bs%3A3%3A%22218%22%3Bi%3A21%3Bs%3A3%3A%22219%22%3Bi%3A22%3Bs%3A3%3A%22220%22%3Bi%3A23%3Bs%3A3%3A%22221%22%3Bi%3A24%3Bs%3A3%3A%22222%22%3Bi%3A25%3Bs%3A3%3A%22223%22%3Bi%3A26%3Bs%3A3%3A%22224%22%3Bi%3A27%3Bs%3A3%3A%22225%22%3Bi%3A28%3Bs%3A3%3A%22226%22%3B%7D&country_id=3&procedure_id=1&table_id=4&x=12&y=17
    
    
    IE9 Compatibility: 
    http://localhost/index.html?row2009_198=117.140&rowcagr_198=62.1&row2009_199=109.580&rowcagr_199=68.2&dataTableArray=a%3A29%3A%7Bi%3A0%3Bs%3A3%3A%22198%22%3Bi%3A1%3Bs%3A3%3A%22199%22%3Bi%3A2%3Bs%3A3%3A%22200%22%3Bi%3A3%3Bs%3A3%3A%22201%22%3Bi%3A4%3Bs%3A3%3A%22202%22%3Bi%3A5%3Bs%3A3%3A%22203%22%3Bi%3A6%3Bs%3A3%3A%22204%22%3Bi%3A7%3Bs%3A3%3A%22205%22%3Bi%3A8%3Bs%3A3%3A%22206%22%3Bi%3A9%3Bs%3A3%3A%22207%22%3Bi%3A10%3Bs%3A3%3A%22208%22%3Bi%3A11%3Bs%3A3%3A%22209%22%3Bi%3A12%3Bs%3A3%3A%22210%22%3Bi%3A13%3Bs%3A3%3A%22211%22%3Bi%3A14%3Bs%3A3%3A%22212%22%3Bi%3A15%3Bs%3A3%3A%22213%22%3Bi%3A16%3Bs%3A3%3A%22214%22%3Bi%3A17%3Bs%3A3%3A%22215%22%3Bi%3A18%3Bs%3A3%3A%22216%22%3Bi%3A19%3Bs%3A3%3A%22217%22%3Bi%3A20%3Bs%3A3%3A%22218%22%3Bi%3A21%3Bs%3A3%3A%22219%22%3Bi%3A22%3Bs%3A3%3A%22220%22%3Bi%3A23%3Bs%3A3%3A%22221%22%3Bi%3A24%3Bs%3A3%3A%22222%22%3Bi%3A25%3Bs%3A3%3A%22223%22%3Bi%3A26%3Bs%3A3%3A%22224%22%3Bi%3A27%3Bs%3A3%3A%22225%22%3Bi%3A28%3Bs%3A3%3A%22226%22%3B%7D&country_id=3&procedure_id=1&table_id=4&x=13&y=16
    
    
    Chrome:
    http://localhost/index.html?row2009_198=117.140&rowcagr_198=62.1&row2009_199=109.580&rowcagr_199=68.2&dataTableArray=a%3A29%3A%7Bi%3A0%3Bs%3A3%3A%22198%22%3Bi%3A1%3Bs%3A3%3A%22199%22%3Bi%3A2%3Bs%3A3%3A%22200%22%3Bi%3A3%3Bs%3A3%3A%22201%22%3Bi%3A4%3Bs%3A3%3A%22202%22%3Bi%3A5%3Bs%3A3%3A%22203%22%3Bi%3A6%3Bs%3A3%3A%22204%22%3Bi%3A7%3Bs%3A3%3A%22205%22%3Bi%3A8%3Bs%3A3%3A%22206%22%3Bi%3A9%3Bs%3A3%3A%22207%22%3Bi%3A10%3Bs%3A3%3A%22208%22%3Bi%3A11%3Bs%3A3%3A%22209%22%3Bi%3A12%3Bs%3A3%3A%22210%22%3Bi%3A13%3Bs%3A3%3A%22211%22%3Bi%3A14%3Bs%3A3%3A%22212%22%3Bi%3A15%3Bs%3A3%3A%22213%22%3Bi%3A16%3Bs%3A3%3A%22214%22%3Bi%3A17%3Bs%3A3%3A%22215%22%3Bi%3A18%3Bs%3A3%3A%22216%22%3Bi%3A19%3Bs%3A3%3A%22217%22%3Bi%3A20%3Bs%3A3%3A%22218%22%3Bi%3A21%3Bs%3A3%3A%22219%22%3Bi%3A22%3Bs%3A3%3A%22220%22%3Bi%3A23%3Bs%3A3%3A%22221%22%3Bi%3A24%3Bs%3A3%3A%22222%22%3Bi%3A25%3Bs%3A3%3A%22223%22%3Bi%3A26%3Bs%3A3%3A%22224%22%3Bi%3A27%3Bs%3A3%3A%22225%22%3Bi%3A28%3Bs%3A3%3A%22226%22%3B%7D&country_id=3&procedure_id=1&table_id=4&x=20&y=11
    Do you perhaps have a sample page up somewhere that could help us identify the problem?
    var details = {
    . . web: "afterlight.com.au",
    . . photos: "jvdl.id.au",
    . . psa: "usethelatestversion.com"
    }

  4. #4
    . shoooo... silver trophy logic_earth's Avatar
    Join Date
    Oct 2005
    Location
    CA
    Posts
    9,013
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    You really need to use POST for this, GET has data limitations both for browsers and on the server side.
    Logic without the fatal effects.
    All code snippets are licensed under WTFPL.


  5. #5
    SitePoint Guru ripcurlksm's Avatar
    Join Date
    Aug 2004
    Location
    San Clemente, CA
    Posts
    859
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've converted everything from GET to POST and still have the same issues. Sending PM's to view it


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •