SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Addict
    Join Date
    Jun 2006
    Posts
    251
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Footer won't clear page in IE

    Hi Peeps,

    Can anyone please tell me how I can get the skyline graphic to clear the page and remain at the bottom of the page?



    many thanks
    Last edited by Paul O'B; Nov 15, 2012 at 06:06. Reason: link removed

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,323
    Mentioned
    462 Post(s)
    Tagged
    8 Thread(s)
    Looks fine in IE to me. Are you viewing this in an outdated version?

  3. #3
    SitePoint Addict
    Join Date
    Jun 2006
    Posts
    251
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks very much for your reply.

    I looks fine on my machine in all versions of IE, and in browserlabs viewer.

    Problem is, on my colleagues machines, the footer is halfway up the page - their using IE 7.0.5730.13 I specifically tested it in this on my machine.

    Do you know why it would look fine on mine but different on someones elses? Even though the browser is the same version?

    I'm completely puzzled..........

  4. #4
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,323
    Mentioned
    462 Post(s)
    Tagged
    8 Thread(s)
    Quote Originally Posted by mattastic View Post
    Do you know why it would look fine on mine but different on someones elses? Even though the browser is the same version?
    Hm, it could be some setting they have ... but I tested in two versions of IE7 and it was fine. Mind you, I've totally abandoned that out of date browser, and don't consider it worth designing for any more.

  5. #5
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,613
    Mentioned
    65 Post(s)
    Tagged
    2 Thread(s)
    IE7 is an old browser eat up with Microsoft-peculiar behavior. I'd like to recommend that you validate the html and make it shine, THEN we can look at the css if a problem still exists. For example, <nav> is not supported in IE8 or earlier, so you should use a <div> instead. Something this simple could be the culprit. In the footer, there is an unmatched (stray) </ul> tag. That, too, might be the bad actor. Gotta start somewhere, and clean HTML is a good foundation.

    Another thing, too. IE7 does not support an XHTML strict doctype, so you would be much better off using an HTML401 doctype. That's a biggie.

  6. #6
    SitePoint Addict
    Join Date
    Jun 2006
    Posts
    251
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks folks, recreated the layout in the end.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •