SitePoint Sponsor

User Tag List

Results 1 to 10 of 10
  1. #1
    SitePoint Guru navyfalcon's Avatar
    Join Date
    Jul 2007
    Location
    So California, Los Angeles county, USA
    Posts
    719
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Links to file in folder "King James" not working but links to file "Reference1" work

    My website "Free Tutorials.name" - (page) Free Internet Resources - "Bible Index" (link not working - does not take you to index)
    works somewhat on computer (desk top) Note: this is a new item
    -
    I have tried several ways to try and correct, including using "../" but i am out of ideas.
    -
    Any help would be appreciated
    -
    Thank You
    falcon
    Many good Free Tutorials at:
    http://freetutorials.name

  2. #2
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,996
    Mentioned
    219 Post(s)
    Tagged
    12 Thread(s)
    Hi,
    I don't know if will help much, but try adding a trailing slash to the directory name.
    Currently it looks like this: http://freetutorials.name/King%20James/#Bible%20Index

    Also, you could try naming the file directly, see if that makes a difference:
    http://freetutorials.name/King%20James/#Bible%20Index/index.html

  3. #3
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,996
    Mentioned
    219 Post(s)
    Tagged
    12 Thread(s)
    Just tried those two suggestions myself - no joy.
    Sorry for the noise.

    It sounds obvious, but just to be sure: the file/path you are trying to access does exist, right? And you do have permission to access this file/path on your server?

  4. #4
    SitePoint Wizard bronze trophy Jeff Mott's Avatar
    Join Date
    Jul 2009
    Posts
    1,311
    Mentioned
    19 Post(s)
    Tagged
    1 Thread(s)
    The problem is because of the "#" in the URL.

    http://freetutorials.name/King%20James/#Bible%20Index
    "First make it work. Then make it better."

  5. #5
    SitePoint Guru navyfalcon's Avatar
    Join Date
    Jul 2007
    Location
    So California, Los Angeles county, USA
    Posts
    719
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Thank You Jeff. Removing the # helped.
    Works on my desktop but not on the internet (tried several variations)
    -
    falcon
    Many good Free Tutorials at:
    http://freetutorials.name

  6. #6
    SitePoint Guru navyfalcon's Avatar
    Join Date
    Jul 2007
    Location
    So California, Los Angeles county, USA
    Posts
    719
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Pullo
    Thank You for viewing and trying to help. I appreciate any help, I need all I can get.
    -
    falcon
    Many good Free Tutorials at:
    http://freetutorials.name

  7. #7
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,293
    Mentioned
    460 Post(s)
    Tagged
    8 Thread(s)
    Quote Originally Posted by navyfalcon View Post
    Works on my desktop but not on the internet (tried several variations)
    Works fine on the internet for me now. Perhaps you need to refresh your browser or clear the cache?

  8. #8
    SitePoint Guru navyfalcon's Avatar
    Join Date
    Jul 2007
    Location
    So California, Los Angeles county, USA
    Posts
    719
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Thank You Ralph
    You are right. The HTML at the end did it.
    Now the index is working. Unfortunately the index links work on my desktop but not on the internet.
    Now checking small items that may prevent it (such as syntax or upper or lower text case)
    any suggestions would be appreciated.
    Thank You
    -
    BTW Schulz helped me change my site from HTML tables to CSS. Helped me a lot to get started. Long time ago
    -
    falcon
    Many good Free Tutorials at:
    http://freetutorials.name

  9. #9
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,293
    Mentioned
    460 Post(s)
    Tagged
    8 Thread(s)
    Quote Originally Posted by navyfalcon View Post
    Unfortunately the index links work on my desktop but not on the internet.
    O, I see—the links on the page itself. Where are they located within your file structure. The links should be easy to fix.

    Off Topic:

    Schulz helped me change my site from HTML tables to CSS. Helped me a lot to get started. Long time ago
    Yes, unfortunately he suffered an early demise about 3 years ago. Very sad.

  10. #10
    SitePoint Guru navyfalcon's Avatar
    Join Date
    Jul 2007
    Location
    So California, Los Angeles county, USA
    Posts
    719
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    It works now. Strange, I had to take the files out of the King James folder ??
    -
    Thanks to everyone who reviewed and replied
    -
    falcon
    Many good Free Tutorials at:
    http://freetutorials.name


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •