SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Enthusiast
    Join Date
    May 2007
    Posts
    50
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    How to use my newly installed php version

    I have installed the latest php version on my mac.
    The problem is that when I create a simple script (with the function phpinfo() in it) the script still uses the old 5.3.x php version that comes with the system.
    Any ideas on how to fix that?

    PS : I followed these instructions (http://mac.tutsplus.com/tutorials/se...mountain-lion/)

    PS2 : I've already put /usr/local/bin first in the path variable, so php -v at the command line gives the latest version (5.4.x)

  2. #2
    SitePoint Addict kduv's Avatar
    Join Date
    May 2012
    Location
    Maui, HI
    Posts
    211
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Installing and updating PHP on my Mac has always been a pain if I do it manually IMO. I've always found it easier to just use MAMP or XAMP.
    Keith
    Freelance web developer
    http://www.duvalltech.com/

  3. #3
    Hosting Team Leader silver trophybronze trophy
    cpradio's Avatar
    Join Date
    Jun 2002
    Location
    Ohio
    Posts
    5,073
    Mentioned
    152 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by skiabox View Post
    I have installed the latest php version on my mac.
    The problem is that when I create a simple script (with the function phpinfo() in it) the script still uses the old 5.3.x php version that comes with the system.
    Any ideas on how to fix that?

    PS : I followed these instructions (http://mac.tutsplus.com/tutorials/se...mountain-lion/)

    PS2 : I've already put /usr/local/bin first in the path variable, so php -v at the command line gives the latest version (5.4.x)
    Did you restart the apache process after doing your changes/upgrade?
    Be sure to congratulate Patche on earning July's Member of the Month
    Go ahead and blame me, I still won't lose any sleep over it
    My Blog | My Technical Notes

  4. #4
    SitePoint Enthusiast
    Join Date
    May 2007
    Posts
    50
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok, finally I managed to install it and it is working fine.You must just pay attention to all the answers on the above thread.
    I manually compiled the IMAP libarries and after removing them from the configuration file I changed icu-config directory from /usr to /usr/local.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •