Hi all,

I'm using Joomla and I updated it to the latest version "3.0.0" .. After that I was surprised to see this message : "Your host needs to use PHP 5.3.1 or higher to run this version of Joomla!".

I was using PHP 5.2.17 and apache 2.2.22 . I contacted the customer service and they told me to use easyapache to upgrade PHP to 5.4 . I used easyApache but it gives me an error (specifically in PHP upgrade) and don't complete the upgrade process.

I tried many tutorials on the internet but they don't make sense. I upgraded Apache to 2.2.23 with "no php" option and when I browse the website it gives me : "Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects."

PHP Code:
root@spes [~]# yum install php 
Loaded pluginsfastestmirror 
Loading mirror speeds from cached hostfile 
 
atomicwww7.atomicorp.com 
 
basecentos.mirroring.pulsant.co.uk 
 
epelmirrors.coreix.net 
 
extrascentos.mirroring.pulsant.co.uk 
 
rpmforgewww.mirrorservice.org 
 
updatescentos.mirroring.pulsant.co.uk 
Setting up Install Process 
No package php available

ErrorNothing to do 
PHP Code:
root@spes [~]# php -v 
PHP 5.2.17 (cli) (builtMay 21 2012 09:24:45
Copyright (c1997-2010 The PHP Group 
Zend Engine v2.2.0
Copyright (c1998-2010 Zend Technologies 
Too complicated, I know, but this is because I have no experience . I'll be so happy with any kind of help or advice. Thanks in Advance.