SitePoint Sponsor

User Tag List

Results 1 to 3 of 3

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    Sep 2012
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy CentOS 6.3 update PHP !!!

    Hi all,

    I'm using Joomla and I updated it to the latest version "3.0.0" .. After that I was surprised to see this message : "Your host needs to use PHP 5.3.1 or higher to run this version of Joomla!".

    I was using PHP 5.2.17 and apache 2.2.22 . I contacted the customer service and they told me to use easyapache to upgrade PHP to 5.4 . I used easyApache but it gives me an error (specifically in PHP upgrade) and don't complete the upgrade process.

    I tried many tutorials on the internet but they don't make sense. I upgraded Apache to 2.2.23 with "no php" option and when I browse the website it gives me : "Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects."

    PHP Code:
    root@spes [~]# yum install php 
    Loaded pluginsfastestmirror 
    Loading mirror speeds from cached hostfile 
     
    atomicwww7.atomicorp.com 
     
    basecentos.mirroring.pulsant.co.uk 
     
    epelmirrors.coreix.net 
     
    extrascentos.mirroring.pulsant.co.uk 
     
    rpmforgewww.mirrorservice.org 
     
    updatescentos.mirroring.pulsant.co.uk 
    Setting up Install Process 
    No package php available

    ErrorNothing to do 
    PHP Code:
    root@spes [~]# php -v 
    PHP 5.2.17 (cli) (builtMay 21 2012 09:24:45
    Copyright (c1997-2010 The PHP Group 
    Zend Engine v2.2.0
    Copyright (c1998-2010 Zend Technologies 
    Too complicated, I know, but this is because I have no experience . I'll be so happy with any kind of help or advice. Thanks in Advance.

  2. #2
    SitePoint Wizard gate2vn's Avatar
    Join Date
    Jan 2004
    Location
    Oslo, Norway
    Posts
    1,056
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    As you mentioned to Easyapache, I assume you are using cPanel/WHM?
    Clustered CloudLinux Hosting | WordPress Hosting |
    Advanced Antispam | Managed Xen VPS
    in US West coast and Asia-Pacific datacenters
    Contact us now on Twitter @vietnap

  3. #3
    Foozle Reducer ServerStorm's Avatar
    Join Date
    Feb 2005
    Location
    Burlington, Canada
    Posts
    2,699
    Mentioned
    89 Post(s)
    Tagged
    6 Thread(s)
    Hi egystu,

    Here is a list of questions that may help us if you provide answers:


    • Have you made extensive php.ini changes where a reinstall versus an update might cause you a problem?
    • What is the error that you get when using EasyApache?
    • How comfortable are you with command line management?
    • Do you know how security and permissions are handled in Linux or more specifically with Apache and Apache's directories?


    In my experience upgrades very often don't work in the Linux world (when speaking about servers) as their are many different ways people secure Linux servers and sometimes even the 'Root' style Sudo commands can't execute installs on files and folders that are protected as ROOT. You may have to run EasyApache using SU instead of Sudo.

    Regards,
    Steve
    ictus==""


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •