SitePoint Sponsor

User Tag List

Results 1 to 10 of 10
  1. #1
    SitePoint Enthusiast
    Join Date
    Nov 2007
    Posts
    44
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Need old version of PHP to use a specific script, what are my options?

    Hello. I need to run PHP 4 to run a script which is not compatible with PHP5. What are my options besides XAMPP? It doesn't seem to work properly, and besides, things are made a bit harder by the fact that I'm running Vista 64-bit.

  2. #2
    Certified Ethical Hacker silver trophybronze trophy dklynn's Avatar
    Join Date
    Feb 2002
    Location
    Auckland
    Posts
    14,672
    Mentioned
    19 Post(s)
    Tagged
    3 Thread(s)
    hawkman,

    Get ahold of an old version of Kevin Yank's book (before he "sold out" to the canned programs) and download and install your daemons individually. If you can't find it, PM me for a copy of the checklist I created from v2. I've also provided guidance to others here for Vista/Win7 installations which basically say to keep everything (but MySQL) out of the Program Files (or other WinDoze-protected directories). Personally, I've installed everything but MySQL on a "Web partition."

    IMHO, the major problem ... er, difference between the two versions in in the mysql/mysqli functions. It's easy enough to update older scripts so I'd recommend PHP5 for the better functions.

    Regards,

    DK
    David K. Lynn - Data Koncepts is a long-time WebHostingBuzz (US/UK)
    Client and (unpaid) WHB Ambassador
    mod_rewrite Tutorial Article (setup, config, test & write
    mod_rewrite regex w/sample code) and Code Generator

  3. #3
    SitePoint Enthusiast
    Join Date
    Nov 2007
    Posts
    44
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I can't program to save my life, and the script I use is a CSV to Mysql import library which doesn't work with PHP5. I would be installing locally so there wouldn't be any security risks, besides having a local installation of Apache would be good for testing other things as well. Problem is XAMPP keeps complaining that port 80 is in use and I don't know what is using it.

  4. #4
    Certified Ethical Hacker silver trophybronze trophy dklynn's Avatar
    Join Date
    Feb 2002
    Location
    Auckland
    Posts
    14,672
    Mentioned
    19 Post(s)
    Tagged
    3 Thread(s)
    hm,

    When I was running XP, IIS was started automatically (by WinDoze) so it had to be stopped and told that it must be manually started (services.msc). Today, you've got to be sure to tell Skype NOT to use port 80 but M$ isn't cornering the market on port 80 any longer (too many complaints?). If you still get a port 80 complaint from XAMPP, run netstat from a DOS prompt and look for :80.

    Finally, the easiest solution might be to look for a current CSV-to-MySQL converter as I'm sure they're around (e.g., http://www.phpclasses.org/package/44...SQL-table.html).

    Regards,

    DK
    David K. Lynn - Data Koncepts is a long-time WebHostingBuzz (US/UK)
    Client and (unpaid) WHB Ambassador
    mod_rewrite Tutorial Article (setup, config, test & write
    mod_rewrite regex w/sample code) and Code Generator

  5. #5
    SitePoint Enthusiast
    Join Date
    Nov 2007
    Posts
    44
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ran netstat this as administrator

    C:\Windows\system32>netstat

    Active Connections

    Proto Local Address Foreign Address State
    TCP 192.168.1.3:49471 atticus:http CLOSE_WAIT
    TCP 192.168.1.3:49472 bots:http CLOSE_WAIT
    TCP 192.168.1.3:49473 mdl:http CLOSE_WAIT
    TCP 192.168.1.3:51840 92.87.232.19:http CLOSE_WAIT
    TCP 192.168.1.3:52215 92.87.232.33:http CLOSE_WAIT
    TCP 192.168.1.3:52323 80.97.208.82:http CLOSE_WAIT
    TCP 192.168.1.3:52324 80.97.208.82:http CLOSE_WAIT
    TCP 192.168.1.3:52452 bud01s11-in-f9:http ESTABLISHED
    TCP 192.168.1.3:52490 pass71:2082 CLOSE_WAIT
    TCP 192.168.1.3:52549 ec2-174-129-229-200:http ESTABLISHED
    TCP 192.168.1.3:52556 65.55.17.76:http ESTABLISHED
    TCP 192.168.1.3:52557 80.97.208.78:http ESTABLISHED
    TCP 192.168.1.3:60708 pass71:2082 CLOSE_WAIT
    TCP 192.168.1.3:60740 pass71:2082 CLOSE_WAIT
    TCP 192.168.1.3:60775 pass71:2082 CLOSE_WAIT
    TCP 192.168.1.3:60781 pass71:2082 CLOSE_WAIT
    TCP 192.168.1.3:60899 pass71:http CLOSE_WAIT
    TCP 192.168.1.3:60903 pass71:http CLOSE_WAIT
    TCP 192.168.1.3:60904 pass71:http CLOSE_WAIT
    TCP 192.168.1.3:60905 pass71:http CLOSE_WAIT
    TCP 192.168.1.3:60906 pass71:http CLOSE_WAIT
    TCP 192.168.1.3:60907 pass71:http CLOSE_WAIT
    TCP 192.168.1.3:60908 pass71:http CLOSE_WAIT
    TCP 192.168.1.3:60909 pass71:http CLOSE_WAIT
    TCP 192.168.1.3:60910 pass71:http CLOSE_WAIT
    TCP 192.168.1.3:60911 pass71:http CLOSE_WAIT
    TCP 192.168.1.3:60912 pass71:http CLOSE_WAIT
    TCP 192.168.1.3:60913 pass71:http CLOSE_WAIT
    TCP 192.168.1.3:64025 vhost:http CLOSE_WAIT

    Not really sure what to make of it, but if the numbers after the colons are ports, than port 80 doesn't seem to be in use. So why does XAMPP complain that it is?

  6. #6
    Certified Ethical Hacker silver trophybronze trophy dklynn's Avatar
    Join Date
    Feb 2002
    Location
    Auckland
    Posts
    14,672
    Mentioned
    19 Post(s)
    Tagged
    3 Thread(s)
    It's my understanding that netstat SHOULD tell you who's connected (internally & externally) to each of your active ports.

    I skipped Vista so I'm not sure how it's configured (with respect to IIS) so you can use services.msc to check that.

    ALSO, Skype likes to steal port 80 (&443) so you may want to check your Skype Options to ensure that the checkbox is NOT checked - then try the installation again.

    Regards,

    DK
    David K. Lynn - Data Koncepts is a long-time WebHostingBuzz (US/UK)
    Client and (unpaid) WHB Ambassador
    mod_rewrite Tutorial Article (setup, config, test & write
    mod_rewrite regex w/sample code) and Code Generator

  7. #7
    SitePoint Enthusiast Dreeass's Avatar
    Join Date
    Sep 2012
    Posts
    52
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by dklynn View Post
    It's my understanding that netstat SHOULD tell you who's connected (internally & externally) to each of your active ports.

    I skipped Vista so I'm not sure how it's configured (with respect to IIS) so you can use services.msc to check that.

    ALSO, Skype likes to steal port 80 (&443) so you may want to check your Skype Options to ensure that the checkbox is NOT checked - then try the installation again.

    Regards,

    DK
    You can easily get around the Skype-port stealing by starting up XAMPP before you run Skype.

  8. #8
    SitePoint Enthusiast
    Join Date
    Nov 2007
    Posts
    44
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I am not running Skype. And IIS is NOT installed. I checked according to the instructions here (http://www.iis.net/learn/install/ins...-and-windows-7). Could it be something buggy in the version of XAMPP I am trying to install?
    Edit:Could it be VMWare?

    http://communities.vmware.com/thread/181181

  9. #9
    SitePoint Author silver trophybronze trophy
    wwb_99's Avatar
    Join Date
    May 2003
    Location
    Washington, DC
    Posts
    10,652
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Run netstat -a , that should help.

    Another good way to figure out is to go to http://localhost and see what responds.

  10. #10
    SitePoint Guru bronze trophy TomB's Avatar
    Join Date
    Oct 2005
    Location
    Milton Keynes, UK
    Posts
    996
    Mentioned
    9 Post(s)
    Tagged
    2 Thread(s)
    There are a couple of options. You'll need to use PHP4 with apache using CGI then:

    Register a .php4 extension and rename all your files (as well as changing references in the files themselves)

    Associate .php extensions with PHP4 on a specific subdomain using vhosts.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •