SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Evangelist
    Join Date
    Dec 2004
    Posts
    419
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    web font not working properly

    Hi,

    I have used a free web template:
    http://speckyboy.com/2011/02/22/free...template-psds/

    Demo: http://webdesigneraid.com/html5/site-01/

    The big bold fonts on that look great - this is how it looks for me in Firefox 15 when viewing the demo site:
    http://www.cherryblossomflorists.com/draft/v1/good.jpg

    But on my version of the same template, which works 100% fine on my local PC, looks wrong when online:
    http://www.cherryblossomflorists.com/draft/v1/

    This screenshot shows what it looks like for me:
    http://www.cherryblossomflorists.com/draft/v1/bad.jpg

    For some reason the web fonts are not working, even though they work fine on my local machine, and also on the demo version of the original template.

    I wondered if anyone might be able to advise re. where I have gone wrong.

    Any advice much appreciated.

    Thanks

  2. #2
    Avid Logophile silver trophy
    ParkinT's Avatar
    Join Date
    May 2006
    Location
    Central Florida
    Posts
    2,337
    Mentioned
    192 Post(s)
    Tagged
    4 Thread(s)
    Looking at the SOURCE of your online version I can see that the CSS references fonts in a folder that I bet you do not have uploaded on your site.
    Code:
    src: url('../fonts/League_Gothic-webfont.eot');
    	src: local('☺'), url('../fonts/League_Gothic-webfont.woff') format('woff'), url('../League_Gothic-webfont.ttf') format('truetype'), url('../fonts/League_Gothic-webfont.svg#webfont1Lb5Pdit') format('svg');
    Remember that those paths are relative to your css file, too.

    Also, because these references are relative, the location of your site (e.g. draft/v1) probably has changed this.
    Don't be yourself. Be someone a little nicer. -Mignon McLaughlin, journalist and author (1913-1983)


    Git is for EVERYONE
    Literally, the best app for readers.
    Make Your P@ssw0rd Secure
    Leveraging SubDomains

  3. #3
    SitePoint Evangelist
    Join Date
    Dec 2004
    Posts
    419
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks - I copied the files from the fonts folder to the v1 folder, and that has fixed it.
    Thanks for your help


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •