SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Enthusiast az0000000's Avatar
    Join Date
    Oct 2006
    Posts
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Exporting SQL database of Latin and Cyrillic content via phpMyAdmin properly

    Hello,
    I have a Joomla 1.5 website with articles in English and Russian. I have exported the SQL database via phpMyAdmin using its default values. After importing the database to a new server i found out that all Russian content has a messed up charset, and looks something like this: О «Бездушной Компьютерной» Музыке

    Then i have opened the database in Notepad++ and indeed all Cyrillic characters are a mess.

    What setting should i set in phpMyAdmin to export the database properly, so Latin and Cyrillic content will be displayed properly?

    My Joomla is utf-8, and so is the database.

    Thank you.

  2. #2
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,997
    Mentioned
    219 Post(s)
    Tagged
    12 Thread(s)
    Hi there,

    Are you viewing your exported data in Notepad++ using the UTF8 encoding?
    This can be found under the setting "Encoding", the fifth item in the menu bar at the top.

    utf8_notepad.png

  3. #3
    SitePoint Enthusiast az0000000's Avatar
    Join Date
    Oct 2006
    Posts
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi,
    Exactly, and i see Cyrillic content messed.

  4. #4
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,997
    Mentioned
    219 Post(s)
    Tagged
    12 Thread(s)
    So when you exported from PHPMyAdmin did you specify the character set as utf-8?

    If not, you can do this by selecting "Export Method" as "Custom", then under "Output" select "utf-8" from the drop down menu.

    FJG2f.png

  5. #5
    SitePoint Enthusiast az0000000's Avatar
    Join Date
    Oct 2006
    Posts
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    My phpMyAdmin looks different actually. I think it was utf-8, i have used default settings, did not change. This is an example page of bad cyryllyc charset: http://azmand.site11.com/index.php?o...main&Itemid=29
    Now my database is utf-8 definitely, i have converted it and tables collation using a common sql query, it did no help anyway.
    Thank you.

  6. #6
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,997
    Mentioned
    219 Post(s)
    Tagged
    12 Thread(s)
    Quote Originally Posted by az0000000 View Post
    I think it was utf-8, i have used default settings, did not change.
    You need to find this out. If you are viewing your exported db file using the uft-8 encoding in Notepad++ (as described above) and you are seeing gobbledygook, then obviously the file wasn't exported correctly.
    Even if your PHPMyAdmin interface looks different, there will be an option to specify the charset upon export.

    Quote Originally Posted by az0000000 View Post
    This is an example page of bad cyryllyc charset: http://azmand.site11.com/index.php?o...main&Itemid=29
    I believe you that you are having the problem that you say you are.

  7. #7
    SitePoint Enthusiast az0000000's Avatar
    Join Date
    Oct 2006
    Posts
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks a bunch for willing to help me everyone.

    I have solved the issue finally. After all the exported database was OK, the issue was appearing when importing the database actually, that's because i was importing it using a tool from the hosting company, that tool was messing up all non latin characters.

    So idecided to give a try to BigDump tool, and this is a very good one, it did it, it preserved the utf8 and latin charset because i told it so.

    Cheers.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •