SitePoint Sponsor

User Tag List

Results 1 to 2 of 2

Hybrid View

  1. #1
    SitePoint Zealot mcd's Avatar
    Join Date
    Dec 2004
    Location
    Caldwell, NJ
    Posts
    111
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Email form triggers error only on specific email addresses

    I set up a simple PHP form on a client's website to send the form data to an email address. It's your basic POST type of form, with an action that hits a php doc with all of the field info and email address to send to.

    It used to work fine. Now it triggers errors only on email addresses within the client's domain. Any email address ending with the client's dot com results in an error. When I test it with my email address or any other email address, it works fine.

    What could be preventing this from working with the client's email addresses?

  2. #2
    SitePoint Wizard wonshikee's Avatar
    Join Date
    Jan 2007
    Posts
    1,223
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    That sounds like an issue with the mail server treating the domain as a local domain. Basically the mail server sees the domain name (example.com) and says "Oh, this is email address belongs to a user on my server, let me route it there.... wait there is no user by this email - ERROR." This is done for performance reason, why check the DNS records when it knows it's a local domain anyway.

    But when it sees your email address (test.com), it knows that test.com isn't local - so it checks the DNS servers for it's MX records and route it accordingly outside the server.

    Hope that makes sense to you, this is a common issue for domains where the emails are managed elsewhere.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •