SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Member
    Join Date
    Sep 2012
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    open link new window not <div> from anchored list

    Hello all. Very excited to find this resource. I'm new to web development and come from a print background and I can see what jem this is.

    Anyway. Thanks, first of all for the help.

    I've set up a fairly simple gallery that displays icons in <li> tags, for each preview image with an <a> tag.
    To make these icons open in my div on the same page I'm targeting the <a> tags in each <li> tag.

    Each icon then opens a preview of the actual image on the same page in a <div> that has been designated to show that preview. The preview image will be clickable for a full screen/blown-up version being displayed via "lightbox". That is fine and works good. My problem is the last <li> is "text not an icon" with a link to the remainder of items in that category.

    The browser is trying to display that link (which is the next actual page) in my <div> dedicated to showing the preview, not in a new window, be it the same page or not.

    Any help? I'd like an answer rather then just the code. Just the code won't help me in the long run when I'm doing this again.
    Thanks so much to anyone looking at this. Cheers.

    Here's the example website. dr-spazmo.graemartin.com

  2. #2
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,705
    Mentioned
    101 Post(s)
    Tagged
    4 Thread(s)
    Quote Originally Posted by Kalgrae View Post
    My problem is the last <li> is "text not an icon" with a link to the remainder of items in that category.

    The browser is trying to display that link (which is the next actual page) in my <div> dedicated to showing the preview, not in a new window, be it the same page or not.
    In which web browser are you seeing this problem? It seems to work without trouble in Chrome and IE. Either that or I'm misunderstanding your problem, or you've already fixed it.
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •