SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Enthusiast
    Join Date
    Nov 2008
    Posts
    42
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    different homepage width sizes ...

    Hello:

    I am totally confused. I write and test my pages on my computer via XAMPP and then upload to my test server for final testing. When I test via XAMPP, 127.0.0.1, everything looks perfect, but when I upload to the test server, it is incorrect. The correct size on the test server that I am trying to achieve is the menu portion and the header bar and main body are about 10 px too short. Can anyone help me please. I know it is bad using the tables for formatting, and I am slowing replacing those, but I need to get the general area formatted properly before I tackle the table replacement.

    Here is the test page:

    http://pepelepew.netne.net/homehome/homehome.php


    Thanks,

  2. #2
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,587
    Mentioned
    65 Post(s)
    Tagged
    2 Thread(s)
    I suggest that you start by validating the html. There are several html tags that are not closed or are out of place (such as <td> tags outside of a table), and more.

    In Firefox, the layout looks good. Without a screen capture from XAMPP to compare, it's difficult to see where the undesired pixels are showing up.

  3. #3
    SitePoint Enthusiast
    Join Date
    Nov 2008
    Posts
    42
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    screen.png

    The funny thing is that the menu bar is 960, while the rest seems to be around 950. I want everything aligned and centered at 960, but I am losing somewhere 10px.

  4. #4
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,587
    Mentioned
    65 Post(s)
    Tagged
    2 Thread(s)
    Excellent. Your screen shot matches the pixel widths in Firefox.

    Have you fixed your HTML yet?

    Out of curiosity, why do you choose XHTML for a page framed with table code? Why not HTML4.01? This is not a relevant question, I'm truly just curious.

  5. #5
    SitePoint Enthusiast
    Join Date
    Nov 2008
    Posts
    42
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    My problem is the other graphics are not as wide as my menu bar. I have everything as 960 but for some reason I lose 10px somewhere/somehow. As for XHTML, I don't care what it is, as long as it works with the least issues/problems.

  6. #6
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,587
    Mentioned
    65 Post(s)
    Tagged
    2 Thread(s)
    Actually, you explained it quite accurately. The GRAPHICS are not as wide as the main menu bar. The borders of the page depicted on homehead.png, homemain.png and homefoot.png, are 952px wide. The main menubar is coded to fill a width of 960px which is does nicely.

    It looks like you need to redraw those page images to appear as 960px.

  7. #7
    SitePoint Enthusiast
    Join Date
    Nov 2008
    Posts
    42
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok, so the issue at hand was ... why is my page via XAMPP so different from my test site. This is priceless !!! Thankfully I am not as stupid as I look. The simple answer to my problem is I WAS USING OLD GRAPHICS !!! Thank you for your time but it is not time for:

    \_/ \_/ \_/ Cheers


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •