SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    Dec 2010
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Joomla 1.5 issue with menu

    hi,

    i am using a template on the joomla 1.5 platform..

    regarding the first 2 tabs/buttons on my top menu, when you are on the page the tab highlights in red like its supposed to (namely the homepage and features page/s). however on the remaining tabs when on those pages the buttons do not highlight when page is active. the same behavior occurs whichever menu u access those pages from (top / side / bottom.). how can i get the buttons to highlight when active like the first 2 do?

    please help

    site is: http://www.dubturbo-2.com/

    thanks

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,172
    Mentioned
    454 Post(s)
    Tagged
    8 Thread(s)
    You can do this purely with CSS, but I'm sure Joomla has a simple way to transfer the "active" class to the current page.

    Thread moved to CMS forum.

  3. #3
    SitePoint Member
    Join Date
    May 2009
    Location
    Richmond, Virginia, United States
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What you can do is change the selectors in the CSS. I noticed for the active links, your CSS refers to #hornav ul li.active > a. Try replacing that with #hornav .active a. This works for me and on one of my sites.
    Nathan Huebner - Y4N Solutions
    "We turn your vision into reality"
    www.yea4nay.com
    "Politicians are like fast food hamburgers, all filler and no meat"


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •