SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Enthusiast
    Join Date
    Aug 2009
    Posts
    97
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Page shifts to left when I load

    Hi

    I have a page with 3 columns and I didn't set it up right.
    When the page loads, and then shifts to the left.
    I can't figure out what I did wrong.
    Attached is my stylesheet.


    styles.zip

  2. #2
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    39,777
    Mentioned
    158 Post(s)
    Tagged
    3 Thread(s)
    Hi Kath,

    We'd need the html that goes with that as CSS on its own means very little and that is some complex css you have there using many negative margins so is too hard to guess what's going on.

    Just post the html inside code tags in your post rather than attaching a zip as its much easier to work with that way. Or even better still provide a link to the page in question.

    When the page loads, and then shifts to the left.
    You will need to clarify exactly what that means and detail what happens and what was supposed to happen

  3. #3
    SitePoint Enthusiast
    Join Date
    Aug 2009
    Posts
    97
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Paul O'B View Post
    Hi Kath,

    We'd need the html that goes with that as CSS on its own means very little and that is some complex css you have there using many negative margins so is too hard to guess what's going on.

    Just post the html inside code tags in your post rather than attaching a zip as its much easier to work with that way. Or even better still provide a link to the page in question.



    You will need to clarify exactly what that means and detail what happens and what was supposed to happen
    Here is the link to the page in question:
    http://career-updates.org/find-jobs-...ohio&x=59&y=31

  4. #4
    Community Advisor silver trophybronze trophy
    dresden_phoenix's Avatar
    Join Date
    Jun 2008
    Location
    Madison, WI
    Posts
    2,728
    Mentioned
    31 Post(s)
    Tagged
    0 Thread(s)
    Try this:
    Code:
     #maincontainer
    {
    width			: 1100px;
    margin		: 0 auto; 	/*Center container on page*/
    }
    
    #contentwrapper
    {
    float			: right;
     width:729px;
     margin-right:190px
    }
    #leftcolumn
    {
    float			: left;
    width			: 180px;	 /*Width of left column in pixel*/
    border-left		: 1px dotted silver;
    }
    
    #rightcolumn
    {
    float			: right;
    width			: 190px;	 /*Width of right column*/
    margin-right:-950px
    
      }
    You can get rid of the "innertube" and "contentcolumn" in your mark up, if you dont need them for something else.
    Also change your doctype to: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

    Hope that helps.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •