SitePoint Sponsor

User Tag List

Results 1 to 9 of 9
  1. #1
    SitePoint Enthusiast
    Join Date
    Jul 2012
    Location
    Tucson, AZ
    Posts
    25
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Transparency Issues with IE8 and Below

    http://goo.gl/PMvYn

    The PNG's seem to display fine in every browser except IE8 and below. Any ideas why this would be?

  2. #2
    . shoooo... silver trophy logic_earth's Avatar
    Join Date
    Oct 2005
    Location
    CA
    Posts
    9,013
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    It is because something is setting a background color on the two "li" (list) elements
    Logic without the fatal effects.
    All code snippets are licensed under WTFPL.


  3. #3
    SitePoint Enthusiast
    Join Date
    Jul 2012
    Location
    Tucson, AZ
    Posts
    25
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by logic_earth View Post
    It is because something is setting a background color on the two "li" (list) elements
    Wouldn't that be affecting all browsers and not just IE?

    I dan't currently test on IE which makes this somewhat of a pain.

  4. #4
    . shoooo... silver trophy logic_earth's Avatar
    Join Date
    Oct 2005
    Location
    CA
    Posts
    9,013
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    I wouldn't know. Using the developer tools in IE their is a background-color being applied to IE 8 and below. Removing that property solves the issue.
    Logic without the fatal effects.
    All code snippets are licensed under WTFPL.


  5. #5
    SitePoint Enthusiast
    Join Date
    Jul 2012
    Location
    Tucson, AZ
    Posts
    25
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Logic! Hopefully I can get this worked out. Really weird that the div is only taking on a grey background in IE.

  6. #6
    SitePoint Enthusiast
    Join Date
    Jul 2012
    Location
    Tucson, AZ
    Posts
    25
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Different color background on images on IE?

    http://goo.gl/PMvYn
    The slideshow images seem to be taking on a grey background only in IE 8 and below by inheriting a color from an LI item. Any idea why this would be?

    Here's a picture of a side by side comparison of Chrome and IE.
    http://img32.imageshack.us/img32/200...20823at554.png

  7. #7
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,165
    Mentioned
    453 Post(s)
    Tagged
    8 Thread(s)
    Looks like you've fixed this by using !important. The style causing the problem is being added inline, probably by the script. Anyhow, the !important overrules it anyway.

  8. #8
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,506
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)
    Jeremy,

    If IE has a silver lining, it would be its intolerance of orphan tags in HTML. That is the first thing to check when experiencing problems with IE. The HTML really should be squeaky clean. The css works better, too.

    The following tags do not have corresponding open tags:

    Line 137 has an unmatched </div>

    Line 331 has an unmatched </span>

    Line 341 has an unmatched </span>

    Line 371 has an unmatched </span>

    Line 417 has an unmatched </span>

    I doubt that css within the body of the page is a good idea, either.

    I do not know if the above findings will help or not, but it is the right place to start before tinkering with the css.

  9. #9
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,506
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)
    A couple more HTML items...

    Line 11 (the favicon line): smart quotes don't work here.

    Line 434, character position 514: a space is needed between the quote and the "s"
    ie: <img style="padding: 5px;"src="http://174.132.149.155
    -------------------------------------------^^


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •