SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Wizard donboe's Avatar
    Join Date
    Jun 2010
    Location
    Netherlands
    Posts
    2,114
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    z-index negative top margin! What am I doing wrong?

    On this website I use a negative top margin and a higher z-index for the content panel (content (our pharmacy) and the sidebar with the brown image at the top). In every browser this is working fine, only in IE the entire content_panel is cut off at the top as you can see at the brown image at the top of the sidebar right. I am looking at it for hours now and have tried many things like giving a very high z-index to #content as well as to the two separate divs .content and .sidebar, but nothing seems to work. Does anyone see what I am doing wrong?

    Thank you in advance
    “Good artists copy, great artists steal” (Pablo Picasso - 1934)

  2. #2
    SitePoint Wizard bronze trophy chris.upjohn's Avatar
    Join Date
    Apr 2010
    Location
    Melbourne, AU
    Posts
    2,192
    Mentioned
    17 Post(s)
    Tagged
    1 Thread(s)
    Try removing the relative position from your #content_panel selector and that should fix the issue.

  3. #3
    SitePoint Wizard donboe's Avatar
    Join Date
    Jun 2010
    Location
    Netherlands
    Posts
    2,114
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi Chris. Thank you very much, that solved the issue indeed
    “Good artists copy, great artists steal” (Pablo Picasso - 1934)


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •