SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Zealot allanlud's Avatar
    Join Date
    Jul 2012
    Location
    Meath, Ireland
    Posts
    120
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Possible Javascript Problem

    Hi all,

    I'm not exactly sure what's going on with what I'm trying to do, but I'm guessing that the files are conflicting, which is not enabling one of them to work.

    Basically I bought a Theme from Theme Forest, it's using WooCommerce and Wordpress as a CMS. I'm not very knowledgable in the PHP Javascript area (still), so I've been doing a lot of editing on the theme in HTML & CSS. I downloaded a slider and customised it to my liking, and when I try to add it to the site, it stops the main Slider from working.

    I'm working on WAMP so won't be able to give you any links to show you what's happening, but here's the line of code that stops the main banner from working. (I can post all other links to javascript files if needed)

    <script type="text/javascript" src="testimonial-box/js/startstop-slider.js"></script>


    Can anyone help me with this, or have any suggestions.

    And another thing is the images from the main slider are showing for about 1 second in a vertical list (underneath the slider area) as the page loads... (Possibly a CSS or Javascript problem)

    All help greatly appreciated.

  2. #2
    Programming Since 1978 silver trophybronze trophy felgall's Avatar
    Join Date
    Sep 2005
    Location
    Sydney, NSW, Australia
    Posts
    16,810
    Mentioned
    25 Post(s)
    Tagged
    1 Thread(s)
    To be able to work out what is causing the conflict we would need to see what code is in testimonial-box/js/startstop-slider.js and also the other JavaScript that you have attached to the page that it is conflicting with.
    Stephen J Chapman

    javascriptexample.net, Book Reviews, follow me on Twitter
    HTML Help, CSS Help, JavaScript Help, PHP/mySQL Help, blog
    <input name="html5" type="text" required pattern="^$">

  3. #3
    SitePoint Zealot allanlud's Avatar
    Join Date
    Jul 2012
    Location
    Meath, Ireland
    Posts
    120
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the reply. I could send you all the Javascript files I have if that's ok? And screenshots too of what's happening and what I'm trying to do.

    I'm fairly certain the other problem I have with the main Slider is just CSS, hopefully I'll be able to sort that one, been at it for a bit now.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •