SitePoint Sponsor

User Tag List

Results 1 to 3 of 3

Hybrid View

  1. #1
    boiler up blackdog's Avatar
    Join Date
    Jul 2002
    Location
    Purdue
    Posts
    1,181
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    httpd.conf and mod_rewrite

    I'm having some issues getting mod_rewrite to work on my brand new server. This is my first time having my own server (as opposed to being on shared hosting where everything is all set up for you) so i'm totally new to all of this. mod_rewrite doesn't seem to be working for me even though my httpd.conf file is showing it enabled and so is my phpinfo(). I'm wondering if there's something else in httpd.conf that I have to change... like maybe something that tells it to ignore .htaccess files.

    Does anyone have any ideas for how I can resolve this?

  2. #2
    Twitter: @TimIgoe silver trophy TimIgoe's Avatar
    Join Date
    Feb 2005
    Location
    Blackpool, UK
    Posts
    1,056
    Mentioned
    27 Post(s)
    Tagged
    1 Thread(s)
    It could well be that the default settings for Apache are prohibiting the overrides - you should set "AllowOverride" i think it is

    http://httpd.apache.org/docs/current/mod/core.html#allowoverride


    You need the FileInfo option allowed

  3. #3
    Certified Ethical Hacker silver trophybronze trophy dklynn's Avatar
    Join Date
    Feb 2002
    Location
    Auckland
    Posts
    14,644
    Mentioned
    19 Post(s)
    Tagged
    3 Thread(s)
    blackdog,

    I have a tutorial in my signature with the modifications necessary to make Apache useful via mod_rewrite. It's tailored to those creating their own test servers (on a WinDoze box) but the commands are the same (although I've been told that you may be looking for apache2.conf rather than httpd.conf in Apache's conf directory). Make the changes, save the file back to the same location and RESTART your Apache daemon (if you can't do that, you'd better go back to using managed services - that's NOT an insult, please, as I've got a dedicated server but rely on managed services for 7/24/365 coverage by sysadmins with the tools to do the job properly).

    While you're in the server's conf file, you may want to uncomment the mod_speling line, too, as that will correct minor typos and capitalization errors in requests - quite a nice feature.

    Regards,

    DK
    David K. Lynn - Data Koncepts is a long-time WebHostingBuzz (US/UK)
    Client and (unpaid) WHB Ambassador
    mod_rewrite Tutorial Article (setup, config, test & write
    mod_rewrite regex w/sample code) and Code Generator


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •