SitePoint Sponsor

User Tag List

Results 1 to 1 of 1
  1. #1
    SitePoint Zealot
    Join Date
    Aug 2009
    Posts
    104
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Feed using php an mysql error

    Hi

    I have tried to write a feed (see attached zip file).

    However when I try to validate it, I get the following errors:
    This is my first time trying to create a feed and I didn't do that well


    This feed does not validate.
    line 13, column 0: Undefined item element: id (3 occurrences) [help]
    <id>14</id>
    line 14, column 0: Undefined item element: gender (3 occurrences) [help]
    <gender>M</gender>
    line 15, column 0: Undefined item element: fname (3 occurrences) [help]
    <fname>Truck</fname>
    line 43, column 0: Missing channel element: description [help]
    </channel>
    line 43, column 0: Missing channel element: link [help]
    </channel>
    line 43, column 0: Missing channel element: title [help]
    </channel>
    In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendations.
    Feeds should not be served with the "text/html" media type [help]
    your feed appears to be encoded as "UTF-8", but your server is reporting "US-ASCII" [help]





    line 43, column 0: Missing atom:link with rel="self" [help]
    Attached Files Attached Files


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •