SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Member
    Join Date
    Aug 2012
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Body Content Issues Suspect CSS Error

    Hey everyone I am trying to set up a new blog and make it match the website using WordPress. I posted this here as I believe it is a CSS issue. Everything seems to have worked however the main body content has no formatting and seems to be all left aligned.

    Am I missing something silly?

    The blog can be found here: http://www.shopforhandmade.com/blog

    Thanks for any input.

    Andrew

  2. #2
    Community Advisor silver trophybronze trophy
    dresden_phoenix's Avatar
    Join Date
    Jun 2008
    Location
    Madison, WI
    Posts
    2,820
    Mentioned
    34 Post(s)
    Tagged
    2 Thread(s)
    Welcome to Sitepoint, TheSchock.

    I dont see any rules for the classes or IDs you have used in you content area. Make sure WP is importing those.

    Also note, tho I didnt do a thorough check of your actual implementation , that CSS rules are case sensitive. That is "Wp-css-rule" is not the same as "wp-css-rule". Rule names must match EXACTLY in the CSS and the markup.

  3. #3
    SitePoint Member
    Join Date
    Aug 2012
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you for the welcome.

    I have created a new theme. Basically a copy of the twentyten theme just renamed. Is it possible I haven't called in the CSS file?

  4. #4
    Community Advisor silver trophybronze trophy
    dresden_phoenix's Avatar
    Join Date
    Jun 2008
    Location
    Madison, WI
    Posts
    2,820
    Mentioned
    34 Post(s)
    Tagged
    2 Thread(s)
    You have a link to 348 style ( I tend to stay way from frameworks so am not familiar with what this does) and the standard wpstyles, that's all. When you inspect your wpstyles.css file you see its 'essentially' empty.. there are no post styles, or even anything that seems to pertain to layouts. Maybe you edited the wpstyles files but didnt save it to the right directory. I would use the WP dashboard to edit WP CSS, it's neither pretty nor handy.. but at least you know the file is going to be linked.

    hope that helps

  5. #5
    SitePoint Member
    Join Date
    Aug 2012
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It appears that my header.php and footer.php modifications are cancelling out the parent style sheet. Will have a closer look in the morning. Thanks for the pointers.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •