SitePoint Sponsor

User Tag List

Results 1 to 11 of 11
  1. #1
    SitePoint Addict mason.sklut's Avatar
    Join Date
    Oct 2006
    Posts
    200
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Browser Dimension Issues

    I just created a simple portfolio site (http://masonsklut.com). I can't figure out the best way to make my site look like this instead of this. I would like to style the site to work with any browser dimensions... Thanks in advance for any suggestions!

    The stylesheet is located at http://masonsklut.com/style.css

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,207
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    I'm not sure of all the implications of this, but to make the layout more friendly and responsive, try removing the red lines below and modifying the last line as shown in blue:

    Code:
    #gallery {
    width: 999px;
    position: absolute;
    top: 0;
    left: 450px;
    margin: 30px 0 0 450px;
    }

  3. #3
    SitePoint Addict mason.sklut's Avatar
    Join Date
    Oct 2006
    Posts
    200
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks! I also noticed on the "contact" page that the colors are not rendering properly in IE.

    The stylesheet for the contact form is http://masonsklut.com/contact/css/default.min.css

  4. #4
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,207
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    Which IE? I see you have some opacity in there and box shadows, which older versions of IE don't understand.

  5. #5
    SitePoint Addict mason.sklut's Avatar
    Join Date
    Oct 2006
    Posts
    200
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    IE 9...

  6. #6
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,207
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    It's being caused by the filters you have in there for IE. My advice would be to get rid of them and never touch them again. They seem to cause all sorts f problems. for older IEs, you could use a transparent background image instead.

  7. #7
    SitePoint Addict mason.sklut's Avatar
    Join Date
    Oct 2006
    Posts
    200
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks - that was the issue!

  8. #8
    SitePoint Addict mason.sklut's Avatar
    Join Date
    Oct 2006
    Posts
    200
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Do you have any suggestions for keeping the "view complete collection" link on the photo page (http://masonsklut.com/photo) visible when the browser dimensions are scaled?

  9. #9
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,207
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    It tays visible for me. What browser is it not working in?

  10. #10
    SitePoint Addict mason.sklut's Avatar
    Join Date
    Oct 2006
    Posts
    200
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    In any browser, when the height of the browser window is scaled before the width, then the link is not visible... Any tricks on how to change that?

  11. #11
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,207
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    You might need to play with code for a "sticky fotter" to avoid that, although I'm not sure how it will play with the JavaScript on that page:

    http://www.sitepoint.com/forums/show...66#post1239966


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •