SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    Jan 2010
    Posts
    91
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Browser compatibilty issues with ie7

    My site looks fine everywhere except ie7:
    -Im getting a large gap below the navbar
    -also the 3 images that appear below the slider display horizontal but should align vertical.

    I would appreciate any help I can get

    thanks

    www.wontoncrunch.ca

  2. #2
    Sploghm bronze trophy Victorinox's Avatar
    Join Date
    Nov 2008
    Posts
    749
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Using the IE Web Developer Tools, moving the "Page Section: Home" HTML comment to before <DIV id=main-content> in the markup made the gap disappear.

    You're using rather extravagant comment formatting. Some browsers, especially early IE versions, are sensitive to comment placement, and it's not impossible that stretching them over multiple lines may cause problems too. I recommend stripping them down to single lines and with single spaces. i.e. <!-- Page Section: Home -->

    Regarding the images, why are they in divs with the class "col_one_third" when the images occupy half the width of the container? This may not make a practical difference as the images simply spill out of the div whatever the browser, but it seems an inaccurate use of the class. A fix is to remove the "col_last" class from divs containing the images.

  3. #3
    SitePoint Enthusiast
    Join Date
    Jan 2010
    Posts
    91
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the help!!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •