SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Zealot tim@getdim's Avatar
    Join Date
    Jul 2012
    Location
    Detroit
    Posts
    162
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Arrow an error occurred while processing this directive

    My website liveoutloudproductions.com has suddenly started giving me the following message near the bottom of the homepage: "an error occurred while processing this directive"

    i cant figure out why this is happening. ive never seen any JS do this before, and there is no server-side coding on this page so it has to be JS or jQuery as im fairly sure neither html nor css generates error messages.

    ive checked the error console and cannot find anything generating this. everything on the page seems to be working normally.

    has anyone run into something like this before?

    could it be google analytics or something like that?

  2. #2
    SitePoint Guru
    Join Date
    Sep 2006
    Posts
    731
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You had only to disable JS to realise that it isn't responsible.

    If you Google the message, you'll see the problem discussed. There can be more than one cause.
    Tab-indentation is a crime against humanity.

  3. #3
    SitePoint Zealot tim@getdim's Avatar
    Join Date
    Jul 2012
    Location
    Detroit
    Posts
    162
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    here is the issue: every discussion on the subject i have found on google is talking about server-side code.
    the page in question (as stated previously) has NO server side coding. it is 100% html, css, and JS.
    and this is the ONLY page on the entire site that is giving me this error message.

    the confusing thing is i do have some server side code in the main site as well as a wordpress installation in a subfolder, however the error message is only appearing on the site's home page, which does not have any server side coding at all.

    I am getting two instances on the error console, both of which say:
    Permission denied for <http://player.vimeo.com> to get property Location.toString

    could this be my problem?
    why would it be doing it on this page and not others that have vimeo players?


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •