SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Jun 2012
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    403 Error in Wordpress Subdirectory Install

    hi guys,

    i know this is a popular topic so sorry for re-posting but here is my problem..

    i created a subdomain in cpanel where i want to install wordpress so it doesnt interfere/over-write the site that already exists. i created a /subdomain and uploaded/extracted the wordpress file so now i have /subdomain/wordpress <--- where all the files are. i ran through the install screens (title, admin user, pword, etc) but when i log into my index.php file i get the following error "403 forbidden - You don't have permission to access /wordpress/ on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

    from the other posts on this topic i figured i needed to create a new .htaccess file in the /wordpress folder where the index.php file is and adjust the line in index.php that points to the wp header file but no dice.

    any advice/suggestions? i kept the .htaccess file in the root public_html folder as is - do i need to make any adjustments there? i dont want the site as it is now to redirect or anything, i just want to install wordpress and create a new blog while the old site stays as is.

    thanks so much!

    ps - the htaccess file i created looks like this (based on what i read in other posts):

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>
    # END WordPress

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,207
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    Hi mar2012. Welcome to the forums.

    If you have created a subdomain, there's no need to place the files in a folder called /wordpress/. You should just be able to go to http://subdomain.mysite.com and view the WP home page.

    Not sure if this is relevant to what you are doing, but that's my first suggestion.

    Another option is to forget about the subdomain and create a folder on the website called /blog/ (or similar) and place all the WordPress files there. Then you would find your blog's home page here:

    http://mysite.com/blog/

    In general, that would be my preferred option.

  3. #3
    SitePoint Member
    Join Date
    Jun 2012
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ralph.m View Post
    Hi mar2012. Welcome to the forums.

    If you have created a subdomain, there's no need to place the files in a folder called /wordpress/. You should just be able to go to http://subdomain.mysite.com and view the WP home page.

    Not sure if this is relevant to what you are doing, but that's my first suggestion.

    Another option is to forget about the subdomain and create a folder on the website called /blog/ (or similar) and place all the WordPress files there. Then you would find your blog's home page here:

    http://mysite.com/blog/

    In general, that would be my preferred option.

    - thanks so much for responding. so i deleted/reinstalled and the install page worked fine redirecting me to http://mysite.com/wordpress/wp-login.php after - its at this point that i am able to log in BUT im redirected to mysite.com/wordpress/wp-admin/ and i get the "403 Forbiden - Forbidden You don't have permission to access /wpblog/wp-admin/ on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request"

    however, if i manually type mysite.com/wordpress/wp-admin/index.php im brought to the dashboard (as a logged in user) - the "Visit my site" link on the top of the dashboard doesnt work though, it brings me to mysite.com/wordpress/ and i get a 403 :?

    i thought it might have something to do w/ the htaccess file ive been seeing a lot of comments about (https://wordpress.org/support/topic/...ectory-install) but that didnt change anything either? do i need to do something to the htaccess file in the root directory (where the site that already exists live? i dont want a redirect or anything right now)

    thanks so much for any advise/feedback!


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •