Lots of gory details in this thread: http://www.sitepoint.com/forums/show...tual-host-prob
I'll try to clean it up.

My devel code is running on a server on my devel machine. I'm gettting my WP content from the DB on a hosted server. I have vhosts set up so that www.example.local brings up my home page. The top nav links from the hosted DB all point to www.example.com/news, for example. So clicking a link takes me away from the code running on localhost and I end up at my hosted site. After much messing around, I realized I needed to do this:

Code:
# /etc/hosts

127.0.0.1	www.example.com.
This causes a recursion error - a server error. I added a directive to my vhosts file. This is apache2 style / directory structure.

Code:
# /etc/apache2/sites-available/www.example.local

LimitInternalRecursion 100
This stops the recursion error in my error.log but I still get a server error. 'swat I remember, anyway.

I put WP in it's own directory according to the codex article on... u guessed? ... "Giving Wordpress its Own Directory".

Clue: I can log in to the admin page at the hosted site with www.example.com/wp-admin but on my local machine, I have to use www.example.local/cms/wp-admin

I set up the rewrite rules for pretty permalinks the same way on both machines and I just checked, there's no /cms/ bit in the rewrite rules, anyway.

Not sure what's going on but help solving this will not only be appreciated, but rewarded with t-shirts (see cross-linked thread) 8) That's how pissed I am.

TIA
Mike