SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Enthusiast
    Join Date
    Oct 2006
    Posts
    48
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    menu does not open in IE8

    The menu works in Chrome and Firefox etc.
    The main menu item Trophies should have a sub menu item, Sports Trophies that opens directly beneath it. That should have a sub menu that opens on the right with 7 items.
    In IE9 it opens only the first item "Sports Trophies" In IE 8 none open.
    I am on a mac, I have tried figuring this out using a simulator but no luck and it is painfully slow
    Any ideas?

    Thanks in advance
    Mark

  2. #2
    SitePoint Enthusiast
    Join Date
    Oct 2006
    Posts
    48
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    oops, can't believe I forgot to post the link, no wonder I did not get any answers!
    http://tonicpit.com/cct2

  3. #3
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    39,868
    Mentioned
    159 Post(s)
    Tagged
    4 Thread(s)
    HI,

    Its the IE gradient filter that is killing Ie8.

    Code:
    #nav ul.sub-menu{
    filter:progid:DXImageTransform.Microsoft.gradient(startColorstr='#454545', endColorstr='#333333');
    }
    Remove it and the menu should return.

    Most of those IE filters can have dramatic effects on the way elements work and I would advise against using them if possible. Just let older browsers degrade nicely.

    (That's a lot of code for such a small effect but that seems to be par for the course as far as html5 is concerned these days.)

  4. #4
    SitePoint Enthusiast
    Join Date
    Oct 2006
    Posts
    48
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks as always you are the man!

  5. #5
    SitePoint Member
    Join Date
    Feb 2014
    Location
    Birmingham, England
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    @Paul thank you man. even i was having the same problem and your suggestion totally worked. Thank you once again


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •