SitePoint Sponsor

User Tag List

Results 1 to 5 of 5

Hybrid View

  1. #1
    SitePoint Enthusiast yangyang's Avatar
    Join Date
    Jun 2007
    Location
    kavoir.com
    Posts
    96
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Using a page (Blog template) for home page blog posts is problematic?

    I bought a few themes that by default don't have blog posts on home page as normal WordPress themes such as Twenty Eleven has. I had to create a page of Blog template and then use it for home page in Settings -> Reading.

    It works, except for the pagination pages aren't redirecting properly AND page number isn't shown in the page title.

    For example, both of these pages are accessible with or without trailing slash:

    http://www.shanghaiwebhosting.com/page/3/
    http://www.shanghaiwebhosting.com/page/3

    And they NEVER redirect to the canonical one as normal WordPress blog pagination pages should. And the page number isn't being displayed in <title></title>, it's just "Page | Shanghai Web Hosting". Seems $paged or $page variable isn't assigned a value or something.

    It's all the same problems with another site that I used a Blog template page for the home page:

    http://www.rackspacereviews.org/page/3/
    http://www.rackspacereviews.org/page/3

    Are both accessible and NEVER redirects. The page number is neither shown in the title tag.

    Any idea why this is happening and how I can fix this? Would it be a theme issue or is it a WordPress bug?

    Thanks!
    I blog about making websites, technically.
    Online image converter - all formats that you can think of.

  2. #2
    SitePoint Enthusiast abdussamad's Avatar
    Join Date
    May 2006
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You'd better contact the theme author for this one.

  3. #3
    SitePoint Enthusiast yangyang's Avatar
    Join Date
    Jun 2007
    Location
    kavoir.com
    Posts
    96
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by abdussamad View Post
    You'd better contact the theme author for this one.
    Thanks for the reply. So it must a theme issue? So normally with WordPress, even the home page is using a Blog template age, they pagination should work as usual, right?
    I blog about making websites, technically.
    Online image converter - all formats that you can think of.

  4. #4
    SitePoint Enthusiast abdussamad's Avatar
    Join Date
    May 2006
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Smile

    Quote Originally Posted by yangyang View Post
    Thanks for the reply. So it must a theme issue? So normally with WordPress, even the home page is using a Blog template age, they pagination should work as usual, right?

    The (lack of) redirection issue is not related to the theme but the incorrect title is. Anyway you can confirm this by changing over to the default theme and seeing if the redirection occurs.

  5. #5
    SitePoint Enthusiast yangyang's Avatar
    Join Date
    Jun 2007
    Location
    kavoir.com
    Posts
    96
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by abdussamad View Post
    The (lack of) redirection issue is not related to the theme but the incorrect title is. Anyway you can confirm this by changing over to the default theme and seeing if the redirection occurs.
    You've got the point. Just got confirmation from the theme team that the page title issue is related to the theme but they probably can't do anything for the redirection issue. Thanks for your help.
    I blog about making websites, technically.
    Online image converter - all formats that you can think of.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •