SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    ********* Wizard silver trophy Cam's Avatar
    Join Date
    Aug 2002
    Location
    Burpengary, Australia
    Posts
    4,495
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)

    Background image

    Hey,

    I think I have this right but I thought I'd check since it's not working properly. Knowing me, I could easily have made a simple error somewhere else which would screw this up but I'll still ask

    PHP Code:
    td.header
    {
        
    text-aligncenter;
        
    background-imageurl(images/header.jpg);

    Is that right?

    Ta

  2. #2
    ********* Wizard silver trophy Cam's Avatar
    Join Date
    Aug 2002
    Location
    Burpengary, Australia
    Posts
    4,495
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    OK, I can't get it to work. I have this in my style sheet -
    PHP Code:
    td.header
    {
        
    height120px;
        
    text-alignright;
        
    v-alignbottom;
        
    background-imageurl(images/header.jpg);

    And it won't work. I know the some of the CSS is working because the scrollbars and text formatting is getting through. When I put that in the style attribute of the <TD> it works fine so I think it's something wrong the the stylesheet.

    PLEASE HELP, I'M GOING CRAZY

    Edit: The text positioning is working with that (ie. bottom right).

  3. #3
    Robert Wellock silver trophybronze trophy xhtmlcoder's Avatar
    Join Date
    Apr 2002
    Location
    A Maze of Twisty Little Passages
    Posts
    6,316
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    Basically v-align in CSS doesn't exist, try:

    td.header {vertical-align: top;}

    I presume you are trying to add a background image to a table division classed "header".

  4. #4
    ********* Wizard silver trophy Cam's Avatar
    Join Date
    Aug 2002
    Location
    Burpengary, Australia
    Posts
    4,495
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Yes, I realised that v-align doesn't exist, it was just a guess when I didn't have time to check

    Thanks for the help but I figured the problem was Smarty trying to parse the CSS because it was in between delimiters. I'm just starting to learn Smarty so I didn't pick up on it until a friend told me Problem solved


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •