SitePoint Sponsor

User Tag List

Results 1 to 9 of 9
  1. #1
    SitePoint Member
    Join Date
    Jun 2010
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Cannot see images on my websit

    Hi

    I have uploaded my first website, I cannot see images, but can see alt message.

    I tested my website on 5 browsers before uploading and could see all the images.

    My ftp says, "this image does not appear to be valid jpg".

    Please help.

    Aslam

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,118
    Mentioned
    448 Post(s)
    Tagged
    8 Thread(s)
    Hi aslamchoudhury. Welcome to the forums.

    Could you post a link to the site? There are various reasons for this, such as:

    - the images weren't uploaded
    - the file paths are wrong somehow (pointing to your local machine?)
    - there was some error in the way you created/names the images ...

    It would be helpful to see your site as a starting point, or you could describe what you have done in detail.
    Facebook | Google+ | Twitter | Web Design Tips | Free Contact Form

    Forum Usage: Tips on posting code samples, images and more

    Forrest Gump: "IE is like a box of chocolates: you never know what you're gonna get."

  3. #3
    SitePoint Member
    Join Date
    Jun 2010
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Link to my website

    Hi

    First of all thanks for reminding me that I should have posted my website link to the forum.

    Here is the link to the website.

    http://www.m25blinds.co.uk

    Regards

    Aslam

  4. #4
    dooby dooby doo silver trophybronze trophy
    spikeZ's Avatar
    Join Date
    Aug 2004
    Location
    Manchester UK
    Posts
    13,806
    Mentioned
    157 Post(s)
    Tagged
    3 Thread(s)
    Aslam

    Make sure that the images you are calling are actually in the folder.
    You are calling images/image1.jpg which doesnt exist!

    In your images folder you have blind1.jpg, blind2.jpg and blind3.jpg
    Mike Swiffin - Community Team Advisor
    Only a woman can read between the lines of a one word answer.....

  5. #5
    SitePoint Member
    Join Date
    Jun 2010
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi
    I have checked and put the images in the root folder m25blinds. I can preview them on all browsers.
    I have uploaded the whole site on the host's server where I can only see footer backgroun, where I should see header background and images (blinds1-3) all as well. Still no joy.

    Aslam

  6. #6
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,118
    Mentioned
    448 Post(s)
    Tagged
    8 Thread(s)
    You've just got to be really careful with paths and names. For example, your logo is called Logo1.jpg, but your link points to logo1.jpg. The capital L makes it a different image. (That's why I keep everything lower case in my code, to avoid at least one easy pitfall.)

    Other links point to an /images/ folder in the root folder, which seems not to exist at all—at least not in that location.
    Facebook | Google+ | Twitter | Web Design Tips | Free Contact Form

    Forum Usage: Tips on posting code samples, images and more

    Forrest Gump: "IE is like a box of chocolates: you never know what you're gonna get."

  7. #7
    Life is not a malfunction gold trophysilver trophybronze trophy
    TechnoBear's Avatar
    Join Date
    Jun 2011
    Location
    Argyll, Scotland
    Posts
    6,088
    Mentioned
    256 Post(s)
    Tagged
    5 Thread(s)
    You still have the wrong image names in your HTML, in that case. The images are called blind1.jpg, blind2.jpg and blind3.jpg - as you've just confirmed - but your page is asking for image1.jpg, image2.jpg and image3..jpg

    blinds.png
    Take plenty of exercise walk round and round the garden
    or
    sign up now for the Isle of Jura 10K or Half Marathon!

  8. #8
    SitePoint Member
    Join Date
    Jun 2010
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi

    With your help I manage to rename all images, reloaded them and now they are visible on the web.

    Thanks
    Aslam

  9. #9
    Life is not a malfunction gold trophysilver trophybronze trophy
    TechnoBear's Avatar
    Join Date
    Jun 2011
    Location
    Argyll, Scotland
    Posts
    6,088
    Mentioned
    256 Post(s)
    Tagged
    5 Thread(s)
    Glad you've got the image problem sorted, but you seem to have uploaded your site to a sub-directory by mistake. The link above no longer works; the address for your home page is now www.m25blinds.co.uk/M25Blinds.co.uk/
    Take plenty of exercise walk round and round the garden
    or
    sign up now for the Isle of Jura 10K or Half Marathon!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •