SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    Jan 2010
    Posts
    91
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Weird javascript issue...browser loads a new page

    When clicking on a node on the map the browser loads a new page.... ? ? ?

    This is how it should work:
    http://www.pcigeomatics.com/myInteractiveMap/

    The error:
    http://www.pcigeomatics.com/index.ph...Itemid=13#tab2

  2. #2
    SitePoint Enthusiast OMGCarlos's Avatar
    Join Date
    Apr 2012
    Location
    Boston, MA
    Posts
    91
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    You have a couple errors with some other scripts which is preventing the javascript from executing correctly.

    It says:
    Uncaught TypeError: Object [object Object] has no method 'addEvent'
    k2.js: line 13

    Just make sure you load the jQuery script before any other javascript file and you should be good to go.

  3. #3
    SitePoint Enthusiast
    Join Date
    Jan 2010
    Posts
    91
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've commented out the other scripts, but it still seems to have the error.
    I've also made sure to load the jQuery before everything else.

    The jQuery seems to start working but then fails...the bottom box begins to fadeOut when the node is clicked, but its the fadeIn that breaks it.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •