SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Wizard Zaggs's Avatar
    Join Date
    Feb 2005
    Posts
    1,045
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    PHP output RSS problem

    Hi Guys!

    I have a PHP script which generates an RSS feed, however there seems to be an issue when displaying foregin characters? Here is the RSS output. Do I need to change anything?

    Code:
    <?xml version="1.0" encoding="UTF-8" ?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom"><channel><title>domain.ee otsingu tulem</title><description>RSS Feed for kandideeri.ee Search</description><link>http://www.domain.ee</link><atom:link href="http://www.domain.ee/rss/rss.php" rel="self" type="application/rss+xml" /><item><title><![CDATA[Klinditeenindaja ehk stiilinõustaja]]></title><description><![CDATA[
    	S'NOB otsib oma toredasse kollektiivi klinditeenindajat ehk stiilinõustajat!
    
    	Kui Sa oled rõõmsameelne suhtleja, särasilmne moehuviline ning soovid töötada S'NOBis klienditeenindaja/stiilinõustajana, siis palun saada oma CV koos kaaskirjaga 21.maiks kristi@snob.ee
    
    
    	S'NOB (www.snob.ee) esindab Taani disainerite kolme trendikat ja kvaliteetset rõivabrändi naistele - S'NOB, S...]]></description><link><![CDATA[http://www.domain.ee/company/snob-baltics/klinditeenindaja-ehk-stiilin-ustaja-1079.html]]></link><guid>http://www.domain.ee/company/snob-baltics/klinditeenindaja-ehk-stiilin-ustaja-1079.html</guid><pubDate>Mon, 14 May 2012 9:08:16 +0000</pubDate></item>
        </channel></rss>

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    23,621
    Mentioned
    413 Post(s)
    Tagged
    7 Thread(s)
    Hm, do you know what encoding your server is using? Or do you have a link to the feed?

  3. #3
    SitePoint Wizard Zaggs's Avatar
    Join Date
    Feb 2005
    Posts
    1,045
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ralph.m View Post
    Hm, do you know what encoding your server is using? Or do you have a link to the feed?
    Sure, you can access the link here.

  4. #4
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    23,621
    Mentioned
    413 Post(s)
    Tagged
    7 Thread(s)
    Try validating your code here and see if fixing the errors helps:

    http://validator.w3.org/feed/


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •