SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Enthusiast
    Join Date
    Jun 2010
    Posts
    46
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Post MySQL ERROR 1436 & ERROR 1062

    Hi All,

    I was trying to import Sakilla database and ran into some problem and would be grateful if someone could help me out please.

    I ran the following command successfully :

    Code:
    /usr/local/zend/mysql/bin/mysql -u root -p < sakila-schema.sql
    but When I ran this command :

    Code:
    /usr/local/zend/mysql/bin/mysql -u root -p < sakila-data.sql
    I got an error after typing my password :

    ERROR 1436 (HY000) at line 81: Thread stack overrun: 5752 bytes used of a 131072 byte stack, and 128000 bytes needed. Use 'mysqld -O thread_stack=#' to specify a bigger stack.

    I tried running it a second time and I got the following output :

    ERROR 1062 (23000) at line 26: Duplicate entry '1' for key 'PRIMARY'

    Once again I would be grateful if you could help me out please.

    Many Thanks,

  2. #2
    SQL Consultant gold trophysilver trophybronze trophy
    r937's Avatar
    Join Date
    Jul 2002
    Location
    Toronto, Canada
    Posts
    39,248
    Mentioned
    59 Post(s)
    Tagged
    3 Thread(s)
    you need to :

    login : /usr/local/zend/mysql/bin/mysql -u root -p

    and then issue the command :

    DROP sakilla;

    then go to your Zend Community Server installation, which comes with a default my.cnf file in which the thread_stack size was set to 128K, and comment out the line in /usr/local/zend/mysql/data/my.cnf, restart the mysql daemon, and vwalah!!! the default is 192K

    rudy.ca | @rudydotca
    Buy my SitePoint book: Simply SQL
    "giving out my real stuffs"


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •