SitePoint Sponsor

User Tag List

Results 1 to 5 of 5

Hybrid View

  1. #1
    SitePoint Addict
    Join Date
    Oct 2010
    Posts
    292
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    phpmyadmin not accepting username and password in mac lion

    please i just installed lion and i tried to log on into phpmyadmin with a username and password i am sure of, and i get
    "#2002 Cannot log in to the MySQL server", i resintalled again but same issue, please any help would be grateful

  2. #2
    SitePoint Addict
    Join Date
    Apr 2009
    Posts
    356
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Is it also a new installation of phpmyadmin? If yes, check that you have phpmyadmin configued properly for authentication. You can set phpmyadmin to use different ways to log in to your mysql server, maybe something got changed in that area.
    Doug G
    =====
    "If you ain't the lead dog, the view is always the same - Anon

  3. #3
    SitePoint Enthusiast OMGCarlos's Avatar
    Join Date
    Apr 2012
    Location
    Boston, MA
    Posts
    91
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I don't know if this is what's happening to you, but I changed "localhost" to "127.0.0.1" and it worked for me. There was a bug a while back where localhost wasn't routing properly.

    If you're logging in with code change:
    $db = mysql_connect("localhost:8888", "user", "pass");
    to
    $db = mysql_connect("127.0.0.1:8888", "user", "pass");

    If you're logging in through the browser, you'll have to go into the config file and change the defaults in there. For the life of me I can't remember what the file was. I use MAMP Lite, so basically all this is done automatically for me...If that doesn't work maybe we can figure something else. It could actually be a number of things

  4. #4
    SitePoint Addict
    Join Date
    Oct 2010
    Posts
    292
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    its a new intallation of phpmyadmin, @omgcarlos, i am login in with the phpmyadmin interface not the code

  5. #5
    SitePoint Addict tom8's Avatar
    Join Date
    Mar 2012
    Location
    New Jersey
    Posts
    310
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I found this article:

    http://stackoverflow.com/questions/1...-issue-on-mamp

    Might worth to check it out.

    I don't own a Mac so I would not know much about the topic.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •