SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Member
    Join Date
    May 2012
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Tried to add facebook like button. Didn't get it to work. Help!

    Hi.

    I'm a proper amateur when it comes to this stuff, but I have created a website on a free web editor called Weebly.com. I downloaded this site I made as a zip-file in order to host it elsewhere. Some problems have occurred as a results of this, but I have so far managed to repair these.

    However I have now tried to add a facebook like-button to this site. I followed the explanation here: http://kb.weebly.com/facebook-like.html


    This worked properly in the weebly editor. This is how it appeared there:




    But this does not work after downloading the site as a zip. Here is how it appear afterwards:



    And the code (after downloading):
    PHP Code:
    <div><div id="784807402536720860" align="center" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><iframe src="//www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.facebook.com%2FOsloRestaurering&amp;send=false&amp;layout=standard&amp;width=450&amp;show_faces=false&amp;action=like&amp;colorscheme=light&amp;font&amp;height=35" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:35px;" allowTransparency="true"></iframe>></div
    Here is also a screen shot taken of the code:


    Any got an idea about what's wrong here?



    PS: Hope this is the right forum to put it in.

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,112
    Mentioned
    448 Post(s)
    Tagged
    8 Thread(s)
    Hi hespo. Welcome to the forums.

    Try replacing the <iframe> ... </iframe> section of code with this:

    Code:
    <iframe src="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.facebook.com%2Fbubbleunder1977&amp;layout=standard&amp;show_faces=false&amp;action=like&amp;colorscheme=light"
            scrolling="no" frameborder="0"
            style="border:none; height:35px; width: 450px;">
    </iframe>
    If that doesn't work, we might need to see you full page code.
    Facebook | Google+ | Twitter | Web Design Tips | Free Contact Form

    Forum Usage: Tips on posting code samples, images and more

    Forrest Gump: "IE is like a box of chocolates: you never know what you're gonna get."

  3. #3
    SitePoint Member
    Join Date
    May 2012
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the welcome.

    It did work in that sense as a facebook-like button appeared, but this button is blank and not specific for my site.

    Here is a screen shot:


    What part of your code must a change in order to get it to point towards my own facebook-page?

    Thanks for all help so far!

  4. #4
    SitePoint Member
    Join Date
    May 2012
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I worked it out myself. Thanks for all help ralph.m!

  5. #5
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,112
    Mentioned
    448 Post(s)
    Tagged
    8 Thread(s)
    Glad you worked it out. Sorry my code wasn't specific enough. I've used it before, but will have to check what I did to make it site-specific.
    Facebook | Google+ | Twitter | Web Design Tips | Free Contact Form

    Forum Usage: Tips on posting code samples, images and more

    Forrest Gump: "IE is like a box of chocolates: you never know what you're gonna get."


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •