SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Hybrid View

  1. #1
    SitePoint Zealot
    Join Date
    Aug 2010
    Posts
    143
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Funky characters received in a mail box

    Hello,

    I send a mailing, and my mailbox at Yahoo and another mailbox at my own domain at thalasoft.com receive it fine with the subject displaying all right as:

    Påminnelse! Le nouveau président de la République : déjeuner - débat du lundi 21 mai à 11h30

    But a user has reported receiving it as:

    P蚓innelse! Le nouveau pr駸ident de la R駱ublique : d駛euner - d饕at du lundi 21 mai 11h30

    He seems to be the only one recipient (of my knowledge) having received it with these funky characters.

    Is there any reason for this ?

    Kind Regards,

  2. #2
    SitePoint Enthusiast OMGCarlos's Avatar
    Join Date
    Apr 2012
    Location
    Boston, MA
    Posts
    91
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    This happens from time to time when you don't properly set your emails encoding. Usually, you'll want to use UTF-8 or ISO-8859 and unless you set this specifically before sending it, your clients inbox will use whatever encoding they have set as default. This is probably why he's the only one receiving those other characters.

    Sometimes you see this on webpages when you see oddly placed ? marks instead of quotes. Same thing. Just make sure to set the encoding and you should be good

  3. #3
    SitePoint Zealot
    Join Date
    Aug 2010
    Posts
    143
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello Carlos,

    Thanks for that comment. I just checked the mail headers and I can see I already have in place a charset. Is that what you are referring about ?

    Here is the full mail:

    From - Fri May 11 10:08:32 2012
    X-Account-Key: account3
    X-UIDL: 1336723522.20280.vps13495.ovh.net,S=1492
    X-Mozilla-Status: 0001
    X-Mozilla-Status2: 00000000
    X-Mozilla-Keys:
    Return-Path: <stephane@thalasoft.com>
    Delivered-To: stephane@thalasoft.com
    Received: (qmail 20275 invoked by uid 1002); 11 May 2012 08:05:22 -0000
    Message-ID: <20120511080522.20274.qmail@vps13495.ovh.net>
    To: Stephane Eybert <stephane@thalasoft.com>
    Subject: Apple
    X-PHP-Originating-Script: 1002:email.php
    From: LearnInTouch <stephane@thalasoft.com>
    Reply-To: LearnInTouch <stephane@thalasoft.com>
    X-Sender: http://www.learnintouch.com
    X-Mailer: PHP(46.105.8.54)
    X-auth-smtp-user: stephane@thalasoft.com
    Date: Fri, 11 May 2012 09:05:22 +0100
    MIME-Version: 1.0
    Content-Type: multipart/mixed;
    boundary="----=_NextPart_6f8b77b36fec526667ef0081eab05ea4"


    ------=_NextPart_6f8b77b36fec526667ef0081eab05ea4
    Content-Type: multipart/alternative;
    boundary="----=_NextPart_395fd965631ecb5f8bf75719073359c9"

    ------=_NextPart_395fd965631ecb5f8bf75719073359c9
    Content-Type: text/plain; charset="ISO-8859-1"
    Content-Transfer-Encoding: 8bit

    <br />
    <br />
    <br />

    ------=_NextPart_395fd965631ecb5f8bf75719073359c9
    Content-Type: multipart/related;
    boundary="----=_NextPart_b98d5de83984b843f0b8f057eb977ba4"

    ------=_NextPart_b98d5de83984b843f0b8f057eb977ba4
    Content-Type: text/html; charset="ISO-8859-1"
    Content-Transfer-Encoding: quoted-printable

    <p>
    <img src=3D"webkit-fake-url://24C0A19F-34FB-4AA9-A838-4839B51E2344/image.tiff" /></p>


    ------=_NextPart_b98d5de83984b843f0b8f057eb977ba4--

    ------=_NextPart_395fd965631ecb5f8bf75719073359c9--

    ------=_NextPart_6f8b77b36fec526667ef0081eab05ea4--

  4. #4
    SitePoint Zealot
    Join Date
    Aug 2010
    Posts
    143
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I did a try again and sent me an email with the subject containing:

    La nouvelle bibliothèque numérique Thérèse

    When opening the mail on Yahoo the subject was displayed fine.

    When opening the same mail from my iPod mail client reader set up to the Yahoo mail account, the subject was displayed with some funky characters instead of the accentuated ones.

    Is the iPod expecting some specific header ?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •