SitePoint Sponsor

User Tag List

Results 1 to 12 of 12
  1. #1
    SitePoint Member
    Join Date
    May 2012
    Location
    Rotterdam, Netherlands, Netherlands
    Posts
    16
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Navbar Order problem

    Hello,

    I have been having an hard time with this navbar. You can check it out on www.pieterwensveen.nl/shafferstudios/

    Problem is, for some reason the links just stop working, next to that, if you go to home or page5, it reverses the order of the navbar.

    If someone can help me with this, I would be grateful.

  2. #2
    SitePoint Member
    Join Date
    May 2012
    Location
    Rotterdam, Netherlands, Netherlands
    Posts
    16
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Now what's quite impressive is that it does things, I didn't order it to do, neither in the HTML nor CSS. For example, if you click on the link to Page1 it changes the logo.

    Now what's quite weird is that these are in total 6 identical HTML files, using 1 CSS file.

  3. #3
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,295
    Mentioned
    460 Post(s)
    Tagged
    8 Thread(s)
    Are you sure you have the same HTML menu code on the Home page as on other pages?

  4. #4
    SitePoint Member
    Join Date
    May 2012
    Location
    Rotterdam, Netherlands, Netherlands
    Posts
    16
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes, I cross checked a dozen times.

    Also, if you try to click on the links, at first they work normally, then all of a sudden it starts using name anchors. Which aren't in the code...

  5. #5
    Community Advisor silver trophybronze trophy
    dresden_phoenix's Avatar
    Join Date
    Jun 2008
    Location
    Madison, WI
    Posts
    2,812
    Mentioned
    34 Post(s)
    Tagged
    2 Thread(s)
    Did you solve this already?
    I would check , not the HTML, but the CASCADE of the CSS. As you didn't give any identifying class to the main navigation list. it is possible that other style sheets override how the LIs are displayed. merely changing li{float:left;} to li{float:right;} ( or viceversa) anywhere in the CSS would cause the problem you have just described.

  6. #6
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,295
    Mentioned
    460 Post(s)
    Tagged
    8 Thread(s)
    Seems to be working fine now. When I first checked, the menu order in the HTML was reversed on the Home page.

  7. #7
    SitePoint Member
    Join Date
    May 2012
    Location
    Rotterdam, Netherlands, Netherlands
    Posts
    16
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Got that order fixed, but now when you click the links, it goes stops working. I think because it tries to use name anchors.

  8. #8
    billycundiff{float:left;} silver trophybronze trophy RyanReese's Avatar
    Join Date
    Oct 2008
    Location
    Whiteford, Maryland, United States
    Posts
    13,708
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    The nav anchors are working for me in Chrome. What browser/setup are you having the issues on?
    Always looking for web design/development work.
    http://www.CodeFundamentals.com

  9. #9
    SitePoint Member
    Join Date
    May 2012
    Location
    Rotterdam, Netherlands, Netherlands
    Posts
    16
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Seems like going to sleep fixed it

  10. #10
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,295
    Mentioned
    460 Post(s)
    Tagged
    8 Thread(s)
    Quote Originally Posted by Carthago View Post
    Seems like going to sleep fixed it
    No, we sent the SitePoint code elves to visit you while you slept. No one ever gives them the credit they deserve.

  11. #11
    billycundiff{float:left;} silver trophybronze trophy RyanReese's Avatar
    Join Date
    Oct 2008
    Location
    Whiteford, Maryland, United States
    Posts
    13,708
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ralph.m View Post
    No, we sent the SitePoint code elves to visit you while you slept. No one ever gives them the credit they deserve.
    Are you calling me short?
    Always looking for web design/development work.
    http://www.CodeFundamentals.com

  12. #12
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,295
    Mentioned
    460 Post(s)
    Tagged
    8 Thread(s)
    Quote Originally Posted by RyanReese View Post
    Are you calling me short?
    No, just naked.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •