SitePoint Sponsor

User Tag List

Results 1 to 3 of 3

Hybrid View

  1. #1
    SitePoint Addict
    Join Date
    Jul 2000
    Location
    North Central AR
    Posts
    231
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I am getting quite frustrated and feeling really stupid.
    I am attempting to install php, apache and mysql locally.
    I am installing php3, apache 1.3.9 and MySQL on Win98 SE. Apache seems to be working fine, same with MySQL, but not php. I get the following errors when I try to run a simple php script:


    Warning: Cannot open 'c:/windows' for reading in - on line 0

    Fatal error: Unable to start browscap module in (null) on line 0
    Unable to start modules

    I was following the local install from phpbuilder.com.
    I know this is probably an easy fix, but my brain does'nt seem to be working. ANY help would be greatly apprciated!
    Thanks

    ronnie
    The largest selection of PLR Articles on the Planet!
    Many Private Label Rights Products.

  2. #2
    SitePoint Wizard
    Join Date
    Apr 2000
    Posts
    1,483
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I recommend upgrading to PHP4, it gives better performance and good instructions for installing on both NT with IIS and 9x with PWS.
    You can find it at http://www.php.net

  3. #3
    SitePoint Wizard
    Join Date
    Jul 1999
    Location
    Chicago
    Posts
    2,629
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Your error probably has something to do with the "Paths and Directories" section in the settings file, C:\windows\php3.ini (if you've already upgraded to 4.0 then the instructions should be somewhat similar). Here is a short description of each...I think what you need to change is the doc_root variable in that section.

    include_path: whenever you include() a file this is where PHP looks if the path isn't absolute, so include("file.php") where include_path = G:\ would tell PHP to open G:\file.php. This is optional, because if it isn't set and file.php exists in the current dir where the PHP file being executed is, PHP won't even think about this setting.

    doc_root: this is the same as PWS/IIS's WWWROOT. The default PWS setting for this is C:\inetpub\wwwroot so you should set doc_root to that, as long as you haven't changed the wwwroot..

    user_dir: nothing to do with your error..

    extension_dir: make sure this is the directory in which you installed PHP. Usually this should just be C:\php3 for PHP3 and C:\php for PHP4.

    Hope this helps..



Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •