SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member
    Join Date
    Apr 2012
    Location
    Las Vegas, NV
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Need Help: Troubleshoot Layout Issues in Firefox, Possibly Other Browsers

    Hello Sitepoint community! First time here so a small introduction is in order. The name's Austin. I'm just starting out in the wonderful world of front-end development.

    I'm still very fresh in web design and humbly come seeking wisdom and expertise.

    I'm actually finishing up with my very first client. It's a basic layout and design for now but will expand as my client's business does. HTML5 & CSS3. The site works flawlessly in Webkit based browsers as well as Opera and IE9. Yet, for whatever reason, Firefox just isn't playing nice.

    I lack the experience necessary to troubleshoot this. I honestly don't know where to begin. I'm not even sure I can accurately describe the issue...so, I pushed everything live in the hope that someone could peruse my code and at least tell me where to begin or what to scrutinize. I'm not looking for a handout. I love web design and coding in part because I take great joy in solving such problems.

    You can find the site at http://lvthreshold.com.

    I can provide screenshots and code if needed. I've been running it through validators and cross-browser tests. I'm personally using Firefox version 3.5.5 on OSX Lion. Written using Coda for Mac.

    Thank you in advance!
    Last edited by TechnoBear; Apr 29, 2012 at 09:35. Reason: Unnecessary link removed.

  2. #2
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,355
    Mentioned
    179 Post(s)
    Tagged
    6 Thread(s)
    Hi Welcome to Sitepoint

    That was a nice introduction but you failed to actually list what the problem was

    I had a quick look in Firefox but didn't notice anything different but I don't have Firefox 3.5 as that is quite a few years old now (we are up to Firefox 11 now).

    You will have to be more specific and direct us to the area that is causing you the problem as its hard to know where to look otherwise unless its something obvious. If its a specific browsers version only then you may also have to provide a screenshot for those of us who don't have that browser any more.

  3. #3
    SitePoint Member
    Join Date
    Apr 2012
    Location
    Las Vegas, NV
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the reply and pointing out what I've left out. I'll get the hang of posting full details soon. :P

    Specifically, the content area is for some reason downsizing to about 50x50 but still retaining the border radius and box shadow properties. It's also duplicating this below the content area and negating the top border of the footer.

    Well, total noob moment. I manually updated Firefox instead of checking for updates within the app and now it's fine. Jeeze. Here I am looking through my code trying to see what went amiss when all along I was just running an ancient version of Firefox.

    Thanks for the help though! Hopefully I won't see this issue again.

    Resolved!

  4. #4
    SitePoint Addict tom8's Avatar
    Join Date
    Mar 2012
    Location
    New Jersey
    Posts
    310
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Yes, thing like this is very easy to overlook. I too could not find anything wrong with the page so I’m glad it is solved.

    BTW, the latest FF is version 12.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •