SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Member
    Join Date
    Apr 2012
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Eclipse 3.6.0 All In One -> subclipse not installing

    Hello,
    I tried installing subclipse through the "Help->Install New Software" and the URL is http://subclipse.tigris.org/update_1.8.x but it fails every time. It shows following items
    ===================================
    1. CollabNet Merge Client 3.0.8
    2. Subclipse (Required) 1.8.8
    3. Subversion Integration for Mylyn 3.x (Optional) 3.0.0
    4. Subversion Client Adapter (required) 1.8.2
    5. Subversion JavaHL 1.7.4.1
    6. Subversion Revision Graph

    ===================================
    I tried them one by one and only the following could be installed, other four failed:
    1. Subversion Client Adapter (required) 1.8.2
    2. Subversion JavaHL 1.7.4.1


    One of the errors I get is:

    An error occurred while collecting items to be installed session context wasprofile=epp.package.php, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=). Comparison method violates its general contract!
    ================================================
    My environment is as follows:


    Is there anything I'm doing wrong?

    I need at least Subclipse 1.8.8 and CollabNet Merge Client 3.0.8 also in addition to Subversion Client Adapter 1.8.2, Subversion JavaHL 1.7.4.1 that I could install.

    Thanks

  2. #2
    Barefoot on the Moon! silver trophy Force Flow's Avatar
    Join Date
    Jul 2003
    Location
    Northeastern USA
    Posts
    4,615
    Mentioned
    56 Post(s)
    Tagged
    1 Thread(s)
    What version of java are you running?

    There might be compatibility issues with java version 7u3 and eclipse 3.6. Either try upgrading to eclipse 3.7 or downgrade to java version 6u31.
    Visit The Blog | Follow On Twitter
    301tool 1.1.5 - URL redirector & shortener (PHP/MySQL)
    Can be hosted on and utilize your own domain

  3. #3
    SitePoint Member
    Join Date
    Apr 2012
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Force.
    I checked my control panel and I see 3 entries there:
    Java 6 update 31,
    Java 7 Update 3,
    Java 7 Update 3 (64-bit)

    Is this the issue that I'm having multiple of them?

  4. #4
    Barefoot on the Moon! silver trophy Force Flow's Avatar
    Join Date
    Jul 2003
    Location
    Northeastern USA
    Posts
    4,615
    Mentioned
    56 Post(s)
    Tagged
    1 Thread(s)
    According to the bug report, the fix appears to be to either upgrade to the latest version of eclipse 3.7, or uninstall java 7.

    https://bugs.eclipse.org/bugs/show_bug.cgi?id=317785
    Visit The Blog | Follow On Twitter
    301tool 1.1.5 - URL redirector & shortener (PHP/MySQL)
    Can be hosted on and utilize your own domain

  5. #5
    SitePoint Member
    Join Date
    Apr 2012
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks a ton, I uninstalled all Java Instances and just installed JRE 6 Update 32, it fixed the issue. Fantastic, precise solution.

    Just one last query, a link to the tutorial / good reference about how to use/connect SVN through the Eclipse would be a great help, though I'll also Google but a link from expert will be more useful. I'm using Eclipse for PHP development.

    How do I mark #4, your response as the solution?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •