SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Enthusiast
    Join Date
    Jan 2005
    Location
    Canada
    Posts
    75
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    prettyPhoto Problem

    Hello everyone,

    I have been trying to get the prettyPhoto plugin to work on my site for days now. Still having trouble getting it to work. Ive tried searching for answers all over and honestly it could be here but Ive noticed many people have different situations. Im sure mines not much different. Finally I decided to post. It seems to load the photo in its own window and not the "lightbox" modal window.

    Firebug does give me this error...
    Code:
    $("a[rel^='prettyPhoto']").prettyPhoto is not a function
    http://joecampoli.com/test/
    Line 441
    http://joecampoli.com/test/ gallery section is where i am testing it.

    Hope someone can help

    Thank you

  2. #2
    SitePoint Enthusiast
    Join Date
    Jan 2005
    Location
    Canada
    Posts
    75
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well all seems to be working now. Hate when you look over the simplest things it seems. Had to place all the code first before any other and all worked fine. Thank you to Todd Temple for pointing this out to me!

  3. #3
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,678
    Mentioned
    99 Post(s)
    Tagged
    4 Thread(s)
    Quote Originally Posted by Vox98 View Post
    Hope someone can help
    It seems to work for me in Chrome.

    With Internet Explorer there is an array not defined error, so I suggest that you either get in touch with the plugin developer, or use a different plugin.
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript

  4. #4
    SitePoint Enthusiast
    Join Date
    Jan 2005
    Location
    Canada
    Posts
    75
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hmmm what version of IE? Works fine in 9

  5. #5
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,678
    Mentioned
    99 Post(s)
    Tagged
    4 Thread(s)
    Quote Originally Posted by Vox98 View Post
    hmmm what version of IE? Works fine in 9
    This is when "Display a notification about every script error" is enabled.
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •