SitePoint Sponsor

User Tag List

Results 1 to 12 of 12
  1. #1
    SitePoint Enthusiast laresistance2's Avatar
    Join Date
    May 2011
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Seeking a good web host that supports PHP 5.4

    Hello,
    I am looking for a web host that supports PHP 5.4 and also Perl and Python (with the option to install Django).

    I found this host http://www.webfaction.com/ but I do not know if it is correct (have you ever used this host)

    Do you know any cheap hosting which supports the requirements that I mentioned.

    Thank you.

  2. #2
    SitePoint Wizard wonshikee's Avatar
    Join Date
    Jan 2007
    Posts
    1,223
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Not sure what your requirements are besides 5.4, but you could look at amazon web service, I believe they have a one year free of their small plan. You have to install everything yourself, they give you a virtual cloud server with your choice of OS.

  3. #3
    SitePoint Enthusiast laresistance2's Avatar
    Join Date
    May 2011
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you, can you give me the link because I can not find the plan which you speak.
    Do you have good experience with Amazon?

  4. #4
    Non-Member MyDomAinZ.us's Avatar
    Join Date
    Feb 2008
    Location
    Fort Bregg, North Carolina, USA
    Posts
    798
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    May we know your budget and webspace requirements?
    Thanks and regard,

  5. #5
    SitePoint Enthusiast laresistance2's Avatar
    Join Date
    May 2011
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi,
    Small budget (between 4 to 44$ by monthly) and a minimum of 50 GB of space with about 1000 visitors a day (this will increase)

  6. #6
    . shoooo... silver trophy logic_earth's Avatar
    Join Date
    Oct 2005
    Location
    CA
    Posts
    9,013
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    You are going to need a bigger budget. Anyways, you want either a dedicated server or VPS that allows you to install your own software (PHP 5.4, Python, etc.) That will cost a pretty penny.
    Logic without the fatal effects.
    All code snippets are licensed under WTFPL.


  7. #7
    SitePoint Zealot coloradojaguar's Avatar
    Join Date
    Sep 2011
    Location
    Southwestern Mountains
    Posts
    144
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Many would be surprised that not all hosts are supporting PHP 5.4 at this point. You could get by with a managed VPS and that way you may not have to install it yourself if the host provides support for that through their managed VPS packages, and many do. VPS hosting is actually more affordable than many think. I also suggest that you find a true hosting company. Amazon is kind of like Godaddy in that they started out offering one thing but now they provide many products instead of one, like hosting. Seek out a specialized company for your hosting and you will find the process and services are much more stream lined and reliable.
    Hosted solutions provider since 1998 - UK, Atlanta, L.A.,
    JaguarPC.com - Managed Hybrid Servers |
    Managed VPS Hosting | Dedicated Servers

  8. #8
    SitePoint Enthusiast laresistance2's Avatar
    Join Date
    May 2011
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Webfaction proposes the installation of Django and PHP 5.4 but I'm a bit skeptical.
    Have you worked with this company.
    Is it reliable?

  9. #9
    Non-Member
    Join Date
    Dec 2011
    Posts
    25
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    In php 5.4 features like register_globals, magic_quotes and safe_mode are no longer available for instance, which might break sites depending on them. Please have look at http://www.php.net/releases/5_4_0.php before choosing php 5.4

  10. #10
    SitePoint Enthusiast laresistance2's Avatar
    Join Date
    May 2011
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by storminternet View Post
    In php 5.4 features like register_globals, magic_quotes and safe_mode are no longer available for instance, which might break sites depending on them. Please have look at http://www.php.net/releases/5_4_0.php before choosing php 5.4
    Yes I know,
    I am looking for just a web host that supports PHP 5.4 because my applications are not compatible with lower versions of 5.4

  11. #11
    Non-Member
    Join Date
    Dec 2011
    Posts
    25
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Though php 5.4 has released it hasn't been included yet by cPanel, Plesk etc. cPanel team is still working on php 5.4 to remove any possible QA issues before they include it in their latest release. For more details you can have look at http://forums.cpanel.net/f145/php-5-...-a-261752.html

  12. #12
    SitePoint Enthusiast laresistance2's Avatar
    Join Date
    May 2011
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I also found a2hosting.com but do not know if it is well...


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •