SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Wizard bronze trophy cydewaze's Avatar
    Join Date
    Jan 2006
    Location
    Merry Land, USA
    Posts
    1,074
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    What would cause Javascript to stop working on an entire website?

    I went into my wife's website yesterday to change some pricing around when I noticed that everything relying on Javascript was no longer working. Everything was working fine on Friday, but something changed between then and last night. I'm getting all the messages in my "noscript" sections telling me to enable Javascript, but it IS enabled. I've checked it from two different machines and in three different browsers, and I've even copied the source code of the page locally to no avail.

    Here's a sampple page: http://www.xpressdanceclasses.com/register/register.cfm

    There's a lot of funky JS in there that was generated by ColdFusion, but I've already tried pulling that out on my local copy, and it didn't help at all.

    What on earth could be causing this?
    <cfset myblog = "http://cydewaze.org/">

  2. #2
    SitePoint Wizard bronze trophy cydewaze's Avatar
    Join Date
    Jan 2006
    Location
    Merry Land, USA
    Posts
    1,074
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    I accidentally figured it out.

    I had a typo in the path to jquery. I didn't expect this to cause all JS on the entire site to stop working, but now that I've fixed the typo, everything seems to work.

    So, note to self: not having jquery loaded for some reason triggers the noscript stuff to appear.
    <cfset myblog = "http://cydewaze.org/">


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •