SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Addict
    Join Date
    Oct 2005
    Posts
    288
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    $ PEAR on Windows XP

    What is the windows (xp) sequence from start->run->cmd to be able to use a $ PEAR command? (And maybe how to search for a module on the PEAR respository).

    My PEAR library appears to be in C:\xampp\php\PEAR

    Thanks much, Brian (grNadpa) Case

  2. #2
    SitePoint Addict
    Join Date
    Oct 2005
    Posts
    288
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Here's what I've found so far.*
    By doing a windows search on C:\Program Files, C:\XAMPP\PEAR, then C:\XAMPP I was able to find C:\xampp\php\go-pear.bat

    So "Start->cmd ->
    (Showing prompts C:\...)
    C: \Documents and Settings\Owner> cd c:\xampp\php
    C:\xampp\php> pear.bat help
    A list appeared, so I decided to ask for help on Search
    C:\xampp\php> pear help Search
    ...

    So, my readings show commands beginning with the dollar sign. So I tried
    C:\xampp\php> $ help Search
    And. of course, I get " '$' is not recognized ..."
    ----
    * I installed my local server and libraries through the XAMPP download and installer

  3. #3
    . shoooo... silver trophy logic_earth's Avatar
    Join Date
    Oct 2005
    Location
    CA
    Posts
    9,013
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    The dollar sign is just a command line symbol from Linux. Basically means, "Run this from a command line."
    Logic without the fatal effects.
    All code snippets are licensed under WTFPL.


  4. #4
    SitePoint Addict
    Join Date
    Jun 2007
    Posts
    396
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Having the same problem here, how would I run something like this from a Windows server?

    $ pear channel-discover pear.phpdoc.org

    Thanks

  5. #5
    Hosting Team Leader silver trophybronze trophy
    cpradio's Avatar
    Join Date
    Jun 2002
    Location
    Ohio
    Posts
    5,131
    Mentioned
    152 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by xkratosx View Post
    Having the same problem here, how would I run something like this from a Windows server?

    $ pear channel-discover pear.phpdoc.org

    Thanks
    Remove the dollar sign from your command. That is just to help you understand that you must run what is after the $ sign in a command prompt window.

    So your command actually is:
    pear channel-discover pear.phpdoc.org

  6. #6
    SitePoint Addict
    Join Date
    Jun 2007
    Posts
    396
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Ah, perfect, thanks so much cpradio - I did try that to no avail before posting, but realised it was also due to the environmental variables not being set correclty (now fixed). thanks again


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •