SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Zealot
    Join Date
    Oct 2002
    Location
    Madison, WI
    Posts
    198
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Problem with IE7 'clearfix' hack

    Hi,

    I recently made some minor changes on this page, and now slide titles don't work in IE7.

    http://servicemasterbuildingservices.com/

    IE8+, Firefox, Chrome all fine (slide titles appear as expected)>

    Any ideas?

    Thanks,

    Ben
    :::::::::::::::::::::::::::::::::::::::::::::::::::
    Versa Studio
    ExpressionEngine experts
    bas (at) versa studio dot com

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,200
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    I'm not sure why it's not working, but my suggestion would be to make the titles part of the images, and use alt text instead of headings.

  3. #3
    SitePoint Zealot
    Join Date
    Oct 2002
    Location
    Madison, WI
    Posts
    198
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It was working before--just something weird about the CSS in IE7.

    Others - ideas?
    :::::::::::::::::::::::::::::::::::::::::::::::::::
    Versa Studio
    ExpressionEngine experts
    bas (at) versa studio dot com

  4. #4
    billycundiff{float:left;} silver trophybronze trophy RyanReese's Avatar
    Join Date
    Oct 2008
    Location
    Whiteford, Maryland, United States
    Posts
    13,622
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    It's not the clearfix causing the issues . You don't set coordinates on the absolutely positioned text elements and as a result, IE has to guess where to place them (all the others do as well, though they guess right).

    You need to set coordinates.
    Code:
    #home-intro #slides-left h3, #home-intro #slides-left h2, #home-intro .left h3{left:0;bottom:0}
    Please do note that my IE7 doesn't work so I had to use the meta IE7 emulate tag to simulate IE7. I saw the problem happening once I did that and through testing, I got it workign for the emulated IE7. So this should work on the real thing .
    Always looking for web design/development work.
    http://www.CodeFundamentals.com

  5. #5
    Non-Member bronze trophy
    Join Date
    Nov 2009
    Location
    Keene, NH
    Posts
    3,760
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Page filled with things I don't consider viable for web deployment -- likely the cause of why I'm seeing four different layouts in for different engines...

    Markup-side my advice is lose the jquery for nothing, the IE conditionals for NOTHING, don't waste your time with the outdated clearfix nonsense, and maybe work on your semantic markup since those don't actually seem to be headings inside that thar list, (either that or they shouldn't be a list!) there's little reason to have separate anchors for the image and 'heading', your comment placements could be tripping IE and FF rendering bugs, maybe actually use the media attribute on all your CSS embeds not just the IE fix one...

    From the page falling apart miserably with images off, to the broken bloated jquery nonsense slideshow overlapping content, to the fixed width layout with inaccessible fixed metric fonts...

    IE7 not clearing is the least of it's issues; I'd advise throwing it all away and starting over from scratch.

  6. #6
    SitePoint Zealot
    Join Date
    Oct 2002
    Location
    Madison, WI
    Posts
    198
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ryan,

    Thanks for your help, that seemed to do the trick!

    Cheers,

    Ben
    :::::::::::::::::::::::::::::::::::::::::::::::::::
    Versa Studio
    ExpressionEngine experts
    bas (at) versa studio dot com

  7. #7
    billycundiff{float:left;} silver trophybronze trophy RyanReese's Avatar
    Join Date
    Oct 2008
    Location
    Whiteford, Maryland, United States
    Posts
    13,622
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by 4midori View Post
    Ryan,

    Thanks for your help, that seemed to do the trick!

    Cheers,

    Ben
    Glad I could be of some help . You're welcome.
    Always looking for web design/development work.
    http://www.CodeFundamentals.com


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •