SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Zealot
    Join Date
    Feb 2011
    Posts
    101
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    <button> submit problem?

    Hi everyone,

    For some time ago, I heard that using the <button></button> to submit a form, is not good - because IE submits the value of the button instead of the inputs in the form.
    Is this true.?

    Because currently I'm working with bootstrap, and I have this login button, which should contain the arrow icon too. like:

    <button type="submit" class="btn btn-primary" name="btnSubmit">Login <i class="icon-arrow-right"></i></button>

    I can't see how I should do it with a normal input button :/

    Hope someone can answer this question!

    Thank you guys!

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    23,598
    Mentioned
    411 Post(s)
    Tagged
    6 Thread(s)
    I've not heard of that problem (or had that problem myself). Maybe it's a problem with an old version of IE? Anyhow, you are better off placing the arrow as a background image on the button anyhow, and that gives you more possibilities then.

  3. #3
    SitePoint Enthusiast
    Join Date
    Apr 2009
    Location
    Greenville, South Carolina, United States
    Posts
    50
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've ran into this issue on IE 7/8. The solution for me at the time was to use input submits.
    Phase 8 Facebook Applications and Web Development


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •