SitePoint Sponsor

User Tag List

Results 1 to 12 of 12

Hybrid View

  1. #1
    SitePoint Addict
    Join Date
    Feb 2009
    Location
    israel
    Posts
    211
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    The code is not passing validation! Any ide why ?

    Hi everyone,
    The following code:
    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=windows-1255" />
    <style type="text/css"> 
      
    </style>
    </head>
    <body>
    	
    	
    </body>
    </html>
    Yields the following notification when i check it in "http://validator.w3.org/check:
    no_validation.gif
    Can anyone explain me please what is my mistake?
    Thanks

  2. #2
    SitePoint Addict tom8's Avatar
    Join Date
    Mar 2012
    Location
    New Jersey
    Posts
    310
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I think the validator fails to recognize windows-1255. Change it to utf-8 will pass.

    Or you could check as XHTML 1.0 Transitional if windows-1255 must use.

  3. #3
    SitePoint Addict tom8's Avatar
    Join Date
    Mar 2012
    Location
    New Jersey
    Posts
    310
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I meant to say strict.

  4. #4
    SitePoint Addict
    Join Date
    Feb 2009
    Location
    israel
    Posts
    211
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Tom8...
    My fault... After I had relaxed I fully read the error notification that says that i forgot to add "<title>"..
    Stupid error ,and I'm sorry to have bothere you with that...

  5. #5
    Non-Member bronze trophy
    Join Date
    Nov 2009
    Location
    Keene, NH
    Posts
    3,760
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by deotpit View Post
    Thanks Tom8...
    My fault... After I had relaxed I fully read the error notification that says that i forgot to add "<title>"..
    Stupid error ,and I'm sorry to have bothere you with that...
    Late to the party, first thing I noticed

  6. #6
    Just Blow It bronze trophy
    DaveMaxwell's Avatar
    Join Date
    Nov 1999
    Location
    Mechanicsburg, PA
    Posts
    7,200
    Mentioned
    105 Post(s)
    Tagged
    1 Thread(s)
    There's something odd in your declaration, though I'm missing what it is (it could be the empty style and body elements). I recreated it though I used strict instead of transitional - you can change it to transitional if you really, REALLY need it...though I'd hope you'd rethink that since there's little good reason to use transitional.

    Code HTML4Strict:
    <!DOCTYPE html 
         PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
         "[URL]http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd[/URL]">
    <html xmlns="[URL]http://www.w3.org/1999/xhtml[/URL]" xml:lang="en" lang="en">
     <head>
      <meta http-equiv="Content-Type" content="text/html; charset=windows-1255" />
      <title>Title of the document</title>
      <style type="text/css">
       P { color: #123123; }
      </style>
     </head>
     <body>
      <p>The content of the document......</p>
     </body>
    </html>
    Dave Maxwell - Manage Your Site Team Leader
    My favorite YouTube Video! | Star Wars, Dr Suess Style

  7. #7
    SitePoint Addict
    Join Date
    Feb 2009
    Location
    israel
    Posts
    211
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Maxwell. I wrote above what was the source of the error... Sorry to have bothered...

  8. #8
    om nom nom nom Stomme poes's Avatar
    Join Date
    Aug 2007
    Location
    Netherlands
    Posts
    10,233
    Mentioned
    47 Post(s)
    Tagged
    1 Thread(s)
    Sometimes, the only way I can find my own idiocy is to make a post about it. Not because someone has the answer for me, but because writing the problem and hitting submit (never before, sigh) makes the answer come to me. Lawlz.

  9. #9
    SitePoint Addict
    Join Date
    Feb 2009
    Location
    israel
    Posts
    211
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Its a relief to know i'm not the only idiot in town :-) (sorry, just trying to joke..)

  10. #10
    om nom nom nom Stomme poes's Avatar
    Join Date
    Aug 2007
    Location
    Netherlands
    Posts
    10,233
    Mentioned
    47 Post(s)
    Tagged
    1 Thread(s)
    Card-carrying idiot here.
    Was just looking for my pencil for 15 minutes. It was in my hand.

  11. #11
    SitePoint Addict
    Join Date
    Feb 2009
    Location
    israel
    Posts
    211
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You dont need a pencil to write a post in a forum..

  12. #12
    om nom nom nom Stomme poes's Avatar
    Join Date
    Aug 2007
    Location
    Netherlands
    Posts
    10,233
    Mentioned
    47 Post(s)
    Tagged
    1 Thread(s)
    But I do need it to write down my grocery list. I'm not hip enough to buy a handheld telephone to do that for me.... I write on little slips of paper.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •