SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Addict Banana Man's Avatar
    Join Date
    Dec 2005
    Posts
    391
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Unwanted Session ID being added to URL's

    Hi,

    I am setting up a navigation menu on a new site im working on that is inking to *.php files. I have not added any php Session ID info to but for some reason when i click a link sometimes this will be appended.

    http://www.mysite.com/test.php?PHPSESSID=8b6b70d2bbc08b3e6bd5adb8d0450ab8

    Here is my navigation menu:

    Code:
    <ul>
    <li><a href="../test.php">HOME</a></li>
    <li><a href="../online-farm/">ONLINE FARM</a></li>
    <li><a href="../grown-locally/">GROWN LOCALLY</a></li>
    <li><a href="../organic-food/">ORGANIC FOOD</a></li>
    </ul>
    I presume it must be some server issue but i dont know what i should be looking into about this? It seems to be very random, most of the time it doesn't add the session id to the URL's but every now and then it appears.

    Anyone know what might be going on here?

    Thanks!

  2. #2
    From space with love silver trophy
    SpacePhoenix's Avatar
    Join Date
    May 2007
    Location
    Poole, UK
    Posts
    5,077
    Mentioned
    103 Post(s)
    Tagged
    0 Thread(s)
    The users that are affected have got the use of cookies disabled on their computer. In php.ini you can change the value of session.use_only_cookies to true (reboot the server after having saved the change) which will force all users to use cookies.

    http://www.php.net/manual/en/session...e-only-cookies
    Community Team Advisor
    Forum Guidelines: Posting FAQ Signatures FAQ Self Promotion FAQ
    Help the Mods: What's Fluff? Report Fluff/Spam to a Moderator

  3. #3
    SitePoint Addict Banana Man's Avatar
    Join Date
    Dec 2005
    Posts
    391
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    It hasn't been released yet so it's just me seeing this issue so far. I havent blocked cookies in the browser i have been testing in. I have just checked it in a few other browsers and it appears to happen whenever i open up a fresh instance of any browser. If i go to the homepage and then click any link the Session ID gets attached but disappears when i click on any subsequent links.

  4. #4
    SitePoint Addict Banana Man's Avatar
    Join Date
    Dec 2005
    Posts
    391
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I've just been in contact with my Hosting company. It was the server that was attaching the Session ID's. This can be switched off with .htaccess file, for anyone with this issue have a look at the solution here:

    http://www.seomoz.org/ugc/removing-p...id-from-an-url


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •