SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    Nov 2009
    Posts
    56
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Flash animation not appearing when site is hosted on another server

    Hi there,

    I have a site http://somdomain.com.au/

    Now if i staged the site on another server and put the following object element, the flash animation doesn't appear:

    <object id="flash_01" classid="clsid:G38CDB6E-AE6D-11cf-96B8-466553540000" width="920" height="225" data="http://somedomain.com.au/gallery.swf?dir=home"> <!-- this is on my server -->

    On the original host this is the object element

    <object id="flash_01" classid="clsid:G38CDB6E-AE6D-11cf-96B8-466553540000" width="920" height="225" data="/gallery.swf?dir=home"> <!-- this is on the original server -->

    Is this something to do with the cross-domain issue?
    How can i solve this?

    Regards,
    Webfreak05
    Last edited by TechnoBear; Mar 31, 2012 at 08:03. Reason: Delinkified example domains.

  2. #2
    billycundiff{float:left;} silver trophybronze trophy RyanReese's Avatar
    Join Date
    Oct 2008
    Location
    Whiteford, Maryland, United States
    Posts
    13,720
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    If you go to the direct link of the flash player, does it work? Does the flash come up? Have you asked for permission to embed their flash? If so, they can probably provide you with some help regarding this .
    Always looking for web design/development work.
    http://www.CodeFundamentals.com

  3. #3
    Non-Member bronze trophy
    Join Date
    Nov 2009
    Location
    Keene, NH
    Posts
    3,760
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    I'd have to see it live on a real site instead of some hypothetical one in order to dial in the problem -- most likely with more code and the full object embed. Are you sure you edited BOTH objects since your example code is IE only? Are you sure on the original location it's being served from the root directory?

    Oh wait, gallery.swf -- is that flash file smart enough to redirect itself to the other domain, or does it assume the files are local to the current HTTP home. that could be it right there. If that's trying to call other files (like say images) it's going to assume those files locations are relative NOT to where the SWF is located, but to where it's being loaded (the html file's location) -- Part of why using flash for something like a gallery is generally a steaming pile of...

    Well, I say that in general about using flash for anything more than video or games... If that's for a normal website gallery type element, welcome to why that for the most part has gone the way of the Dodo alongside flash banners, flash navigation, and all the other flashtard nonsense that proved there's a reason it's called flash...

    ... and not substance.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •