SitePoint Sponsor

User Tag List

Results 1 to 10 of 10
  1. #1
    SitePoint Member
    Join Date
    Apr 2010
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy Error message when trying to upload

    I'm gettting an error message that says
    You don't have permission to access this server
    Additionally, a 404 Not Found eror was encountered while trying to use an error document to handle the request
    Apache server Port 80

  2. #2
    Life is not a malfunction gold trophysilver trophybronze trophy
    TechnoBear's Avatar
    Join Date
    Jun 2011
    Location
    Argyll, Scotland
    Posts
    5,342
    Mentioned
    214 Post(s)
    Tagged
    5 Thread(s)
    What were you trying to upload, where and how?

  3. #3
    SitePoint Member
    Join Date
    Apr 2010
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I was uploading a practice page from filezilla to godaddy hosting

  4. #4
    <title class="lol"> bronze trophy TehYoyo's Avatar
    Join Date
    Feb 2012
    Location
    Northeast Chicago Suburbs
    Posts
    806
    Mentioned
    18 Post(s)
    Tagged
    1 Thread(s)
    Have you tried calling their customer support? Do they have live chat?

    ~TehYoyo

  5. #5
    Life is not a malfunction gold trophysilver trophybronze trophy
    TechnoBear's Avatar
    Join Date
    Jun 2011
    Location
    Argyll, Scotland
    Posts
    5,342
    Mentioned
    214 Post(s)
    Tagged
    5 Thread(s)
    Are you sure you have the correct settings in Filezilla? Have you uploaded anything successfully before? I'm a bit bewildered here, as 404 is an error message I'd expect to see when trying to read a page, rather than upload one.

    Does godaddy have some kind of FTP lock? Some hosting companies have a security feature where you have to change a setting in your control panel before you can upload files, and you change it back when you've finished.

  6. #6
    Foozle Reducer ServerStorm's Avatar
    Join Date
    Feb 2005
    Location
    Burlington, Canada
    Posts
    2,699
    Mentioned
    89 Post(s)
    Tagged
    2 Thread(s)
    Hi Lorster,

    If you were using filezilla then you would not use port 80. For godaddy.com you would likely use port 21. In filezilla you would use the password and username that they set for you and need to select port 21. Then try to connect.
    ictus==""

  7. #7
    SitePoint Member
    Join Date
    Apr 2010
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The port 80 was part of the error message.
    I used port 21
    The entire question I entered was the error message short of my www address

  8. #8
    <title class="lol"> bronze trophy TehYoyo's Avatar
    Join Date
    Feb 2012
    Location
    Northeast Chicago Suburbs
    Posts
    806
    Mentioned
    18 Post(s)
    Tagged
    1 Thread(s)
    Maybe you should try using port 80? (I don't know much about uploading)

    Try leaving the port blank. FileZilla auto-fills it. Also, try what TechnoBear said (the security option thing).

    ~TehYoyo

  9. #9
    SitePoint Member
    Join Date
    Apr 2010
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'll start over
    I uploaded the file from filezilla. My host is Go Daddy.
    When I checked to see the uploaded page I got the error message that I questioned.
    This is my first time ever uploading

  10. #10
    Foozle Reducer ServerStorm's Avatar
    Join Date
    Feb 2005
    Location
    Burlington, Canada
    Posts
    2,699
    Mentioned
    89 Post(s)
    Tagged
    2 Thread(s)
    Quote Originally Posted by Lorster View Post
    I'll start over
    Quote Originally Posted by Lorster View Post
    I uploaded the file from filezilla. My host is Go Daddy.
    When I checked to see the uploaded page I got the error message that I questioned.
    This is my first time ever uploading
    Ok gotcha,

    Do you know if there is .htaccess file in your root? The reason I ask is the error that you receive is most commonly when apache does not have the <Directory> directive set i.e.

    They may have set this
    Code:
    <Directory />
       Order Deny,
       Allow  Deny from all
       Options None
       AllowOverride None
    </Directory>
    But did not include an overide for your directory like this.
    Code:
    <Directory /Your_Site_Directory>
       Order Deny,Allow
       Allow from All
    </Directory>    


    It should read like:
    Code:
    <Directory />
       Order Deny,Allow
       Deny from all
       Options None
       AllowOverride None
    </Directory>
    <Directory /Your_Site_Directory>
       Order Allow,Deny
       Allow from all
    </Directory>
    The other thing is permissions on the file. If apache is setup to use www-data as the authorized user then if the files are load as ROOT you will also get this error.

    I would talk to godaddy support and make sure that the permissions are masked properly for your virtual host, I would also get them to review the apache virtual host config to ensure that users have the right to browse your files.

    Hope this helps,
    Steve
    ictus==""


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •