SitePoint Sponsor

User Tag List

Results 1 to 3 of 3

Hybrid View

  1. #1
    Now available in Orange Tijmen's Avatar
    Join Date
    Jul 2004
    Location
    The Netherlands
    Posts
    1,469
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Radio button check for group on works they are all empty?

    I'm not sure what I'm doing wrong here. I have this quiz with multiple question. The idea is to check that for every group at least one radio button is checked.

    The problem is that this only seems to work when none of the radio buttons are checked at all. Then it shows the alert box with 1,2,3 is empty. But when you then select one answer for one of the question, and resubmit it, no alert box shows up at all. Even though 2 groups are still without an answer? Any idea why this is?

    You see the example here -> http://tijmensmit.com/dev/input.html
    Travel Photos on Flickr - Twitter

    “Never give up. Never surrender”

  2. #2
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,702
    Mentioned
    101 Post(s)
    Tagged
    4 Thread(s)
    It's your @ symbols that are causing things to go wrong. They were deprecated in jQuery 1.2 and removed in 1.3
    http://api.jquery.com/category/selec...ute-selectors/

    Get rid of those @ symbols, and things will work.
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript

  3. #3
    Now available in Orange Tijmen's Avatar
    Join Date
    Jul 2004
    Location
    The Netherlands
    Posts
    1,469
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    That fixed it, thanks
    Travel Photos on Flickr - Twitter

    “Never give up. Never surrender”


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •